summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-08-27 13:16:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-28 00:25:56 +0100
commit6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3 (patch)
tree2fd015e6aca0bf8be7466444770099501947255f /meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
parentda6260f95f4adcca22da9b0d5fb26e93c0a2517f (diff)
downloadpoky-6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3.tar.gz
meta-yocto-bsp: Add genericx86-64 machine
Duplicate the genericx86 machine, but select x86_64 tunables and use the common-pc-64 linux-yocto KMACHINE and config. This has been boot tested with core-image-sato on a Lenovo x220 (Core-i5) and a Supermicro MBD-X8DTL-iF-O (dual-socket Xeon 5680). (From meta-yocto rev: 9b7db7ded0e6b7f5c0cd3ab7fbb0bce4112407da) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Ross Burton <ross.burton@intel.com> Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 5756e4c219..c3968ef9cf 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,19 +1,23 @@
1KBRANCH_genericx86 = "standard/common-pc/base" 1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
2KBRANCH_routerstationpro = "standard/routerstationpro" 3KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard" 5KBRANCH_beagleboard = "standard/beagleboard"
5 6
6KMACHINE_genericx86 ?= "common-pc" 7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
7 9
8SRCREV_machine_genericx86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0" 10SRCREV_machine_genericx86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
11SRCREV_machine_genericx86-64 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
9SRCREV_machine_routerstationpro ?= "3991d03bd450e9363d5b6e97ede0628ba073db79" 12SRCREV_machine_routerstationpro ?= "3991d03bd450e9363d5b6e97ede0628ba073db79"
10SRCREV_machine_mpc8315e-rdb ?= "8d8339af518104db03f9c36b82f4372569e55b0a" 13SRCREV_machine_mpc8315e-rdb ?= "8d8339af518104db03f9c36b82f4372569e55b0a"
11SRCREV_machine_beagleboard ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0" 14SRCREV_machine_beagleboard ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
12 15
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
13COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 18COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
14COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 19COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
15COMPATIBLE_MACHINE_beagleboard = "beagleboard" 20COMPATIBLE_MACHINE_beagleboard = "beagleboard"
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17 21
18# routerstationpro has a flash size of 16mb 22# routerstationpro has a flash size of 16mb
19KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216" 23KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"