summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorAlejandro Hernandez Samaniego <alejandro@enedino.org>2023-01-11 21:34:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-12 23:08:58 +0000
commit6bcbbd9ee3d2001cc26a4493aeb0d9cdd1b5239d (patch)
tree144d491b19d7ccde75658f599a264f7d16a43d65 /meta-skeleton
parent1149b4fbb6002aa5a4cfe90bd404834721593968 (diff)
downloadpoky-6bcbbd9ee3d2001cc26a4493aeb0d9cdd1b5239d.tar.gz
baremetal-helloworld: Move from skeleton to recipes-extended matching what rust-hello-world is doing
(From OE-Core rev: 13916de0145f83bb28323f0a6bde5c3d503c1319) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
deleted file mode 100644
index fede17b0f0..0000000000
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "Baremetal examples to work with the several QEMU architectures supported on OpenEmbedded"
2HOMEPAGE = "https://github.com/aehs29/baremetal-helloqemu"
3DESCRIPTION = "These are introductory examples to showcase the use of QEMU to run baremetal applications."
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
6
7SRCREV = "22016ecbb9fb6c5f3a7a06698aea7ff8a701c166"
8PV = "0.1+git${SRCPV}"
9
10SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
11
12S = "${WORKDIR}/git"
13
14# The following variables should be set to accomodate each application
15BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}"
16IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}"
17IMAGE_NAME_SUFFIX ?= ""
18
19# Baremetal-Image creates the proper wiring, assumes the output is provided in
20# binary and ELF format, installed on ${base_libdir}/firmware/ , we want a
21# package to be created since we might have some way of updating the baremetal
22# firmware from Linux
23inherit baremetal-image
24
25
26# startup code for x86 uses NASM syntax
27DEPENDS:qemux86:append = " nasm-native"
28
29# These parameters are app specific for this example
30# This will be translated automatically to the architecture and
31# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
32# but the examples can also be run on other architectures/machines
33# such as vexpress-a15 by overriding the setting on the machine.conf
34COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64|qemuriscv32|qemux86|qemux86-64"
35
36BAREMETAL_QEMUARCH ?= ""
37BAREMETAL_QEMUARCH:qemuarmv5 = "versatile"
38BAREMETAL_QEMUARCH:qemuarm = "arm"
39BAREMETAL_QEMUARCH:qemuarm64 = "aarch64"
40BAREMETAL_QEMUARCH:qemuriscv64 = "riscv64"
41BAREMETAL_QEMUARCH:qemuriscv32 = "riscv32"
42BAREMETAL_QEMUARCH:qemux86 = "x86"
43BAREMETAL_QEMUARCH:qemux86-64 = "x86-64"
44
45EXTRA_OEMAKE:append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
46
47# qemux86-64 uses a different Makefile
48do_compile:prepend:qemux86-64(){
49 cd x86-64
50}
51
52# Install binaries on the proper location for baremetal-image to fetch and deploy
53do_install(){
54 install -d ${D}/${base_libdir}/firmware
55 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
56 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
57}
58
59FILES:${PN} += " \
60 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \
61 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \
62"
63
64# qemux86-64 boots from iso rather than -kernel, create image to boot from
65do_image:append:qemux86-64(){
66 dd if=/dev/zero of=${B}/build/img.iso bs=1M count=10 status=none
67 dd if=${B}/build/stage1.bin of=${B}/build/img.iso bs=512 count=1 conv=notrunc
68 dd if=${B}/build/stage2.bin of=${B}/build/img.iso bs=512 seek=1 count=64 conv=notrunc
69 dd if=${B}/build/hello_baremetal_x86-64.bin of=${B}/build/img.iso bs=512 seek=65 conv=notrunc
70 install ${B}/build/img.iso ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.iso
71}