summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorAlejandro Hernandez Samaniego <alejandro@enedino.org>2021-05-10 23:31:34 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-12 23:06:04 +0100
commit4ba09d6a2b6f100eb68dfc6940b5c1c0b74c18f3 (patch)
tree6e82aeeae6f8da12bd02af6e7675176af1d94afd /meta-skeleton
parentd875ba64e9c66543bc47c2518f27651b67be8a7e (diff)
downloadpoky-4ba09d6a2b6f100eb68dfc6940b5c1c0b74c18f3.tar.gz
baremetal-helloworld: Enable RISC-V 64 port
Add support for MACHINE=qemuriscv64. $ runqemu nographic KERNEL: [tmp/deploy/images/qemuriscv64/baremetal-helloworld-image-qemuriscv64.bin] MACHINE: [qemuriscv64] FSTYPE: [bin] runqemu - INFO - Running tmp/work/x86_64-linux/qemu-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/qemu-system-riscv64 Hello OpenEmbedded on RISC-V 64! (From OE-Core rev: 31fde82640bf0d185eab55d2cbaf663c9faae801) Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
index ee945c1ff0..19ef16988f 100644
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "These are introductory examples to showcase the use of QEMU to ru
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
6 6
7SRCREV = "99f4fa4a3b266b42b52af302610b0f4f429ba5e3" 7SRCREV = "0bf9ea216e6f76be50726a3a74e527b7bbb0ad93"
8PV = "0.1+git${SRCPV}" 8PV = "0.1+git${SRCPV}"
9 9
10SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master" 10SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
@@ -28,12 +28,13 @@ inherit baremetal-image
28# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57 28# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
29# but the examples can also be run on other architectures/machines 29# but the examples can also be run on other architectures/machines
30# such as vexpress-a15 by overriding the setting on the machine.conf 30# such as vexpress-a15 by overriding the setting on the machine.conf
31COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64" 31COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64"
32 32
33BAREMETAL_QEMUARCH ?= "" 33BAREMETAL_QEMUARCH ?= ""
34BAREMETAL_QEMUARCH_qemuarmv5 = "versatile" 34BAREMETAL_QEMUARCH_qemuarmv5 = "versatile"
35BAREMETAL_QEMUARCH_qemuarm = "arm" 35BAREMETAL_QEMUARCH_qemuarm = "arm"
36BAREMETAL_QEMUARCH_qemuarm64 = "aarch64" 36BAREMETAL_QEMUARCH_qemuarm64 = "aarch64"
37BAREMETAL_QEMUARCH_qemuriscv64 = "riscv64"
37 38
38EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1" 39EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
39 40