summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
new file mode 100644
index 0000000000..c40b393fa4
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Example of how to build an external Linux kernel module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4
5inherit module
6
7PR = "r0"
8PV = "0.1"
9
10SRC_URI = "file://Makefile \
11 file://hello.c \
12 file://COPYING \
13 "
14
15S = "${WORKDIR}"
16
17# The inherit of module.bbclass will automatically name module packages with
18# "kernel-module-" prefix as required by the oe-core build environment.