summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta-skeleton/recipes-kernel/hello-mod/files/Makefile
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/files/Makefile b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 0000000000..4ded35fbc3
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
1obj-m := hello.o
2
3SRC := $(shell pwd)
4
5all:
6 $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
7
8modules_install:
9 $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
10
11clean:
12 rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
13 rm -f Module.markers Module.symvers modules.order
14 rm -rf .tmp_versions Modules.symvers