diff options
author | Ross Burton <ross.burton@arm.com> | 2022-05-06 16:56:00 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-05-07 22:31:21 +0100 |
commit | f28cca6abcae12ef4d4c4b5299f993b7acbcf4bd (patch) | |
tree | 1a80ac4bd0c48f8915ef4e9fe8d3b80f8b05f8fe /meta-selftest | |
parent | 1d1b19f2d14573264f9c361eaa3676c94bf80cd7 (diff) | |
download | poky-f28cca6abcae12ef4d4c4b5299f993b7acbcf4bd.tar.gz |
oeqa/selftest: add test for git working correctly inside pseudo
The fix for CVE-2022-24765 in git[1] breaks any use of git inside
pseudo. Add a simple test case to oe-selftest to verify that at least
basic uses of git work fine under pseudo.
[1] https://github.com/git/git/commit/8959555cee7ec045958f9b6dd62e541affb7e7d9
(From OE-Core rev: 46822268040a23dbb81f71fe35aee8c2663a31f6)
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r-- | meta-selftest/recipes-test/git-submodule-test/git-submodule-test.bb | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/git-submodule-test/git-submodule-test.bb b/meta-selftest/recipes-test/git-submodule-test/git-submodule-test.bb index cc5d7eae5a..fa3041b7d8 100644 --- a/meta-selftest/recipes-test/git-submodule-test/git-submodule-test.bb +++ b/meta-selftest/recipes-test/git-submodule-test/git-submodule-test.bb | |||
@@ -7,3 +7,18 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
7 | 7 | ||
8 | SRC_URI = "gitsm://git.yoctoproject.org/git-submodule-test;branch=master" | 8 | SRC_URI = "gitsm://git.yoctoproject.org/git-submodule-test;branch=master" |
9 | SRCREV = "a2885dd7d25380d23627e7544b7bbb55014b16ee" | 9 | SRCREV = "a2885dd7d25380d23627e7544b7bbb55014b16ee" |
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | do_test_git_as_user() { | ||
14 | cd ${S} | ||
15 | git status | ||
16 | } | ||
17 | addtask test_git_as_user after do_unpack | ||
18 | |||
19 | fakeroot do_test_git_as_root() { | ||
20 | cd ${S} | ||
21 | git status | ||
22 | } | ||
23 | do_test_git_as_root[depends] += "virtual/fakeroot-native:do_populate_sysroot" | ||
24 | addtask test_git_as_root after do_unpack | ||