summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorFrederic Martinsons <frederic.martinsons@gmail.com>2023-04-27 17:12:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 11:07:26 +0100
commite7e7999b2390f26e0cc6cd4e0fbfd43bcd270862 (patch)
tree54b6509d240b2faaaea624cd55b98f6ff757c9fa /meta-selftest
parenteb1cc1e319ef69419af2223d4bde2761ff202c5d (diff)
downloadpoky-e7e7999b2390f26e0cc6cd4e0fbfd43bcd270862.tar.gz
zvariant: add ptest feature for zvariant test suite
Below is the output of run-ptest script under qemu root@qemux86-64:~# /usr/lib/zvariant/ptest/run-ptest running 37 tests test framing_offset_size::tests::framing_offset_size_bump ... ok$<2> test owned_value::tests::from_value ... ok$<2> test object_path::unit::owned_from_reader ... ok$<2> test str::tests::from_string ... ok$<2> test signature::tests::signature_slicing ... ok$<2> test str::tests::test_ordering ... ok$<2> test owned_value::tests::map_conversion ... ok$<2> test owned_value::tests::serde ... ok$<2> test tests::enums ... ok$<2> test tests::derive ... ok$<2> test tests::f64_value ... ok$<2> test tests::i16_value ... ok$<2> test tests::fd_value ... ok$<2> test tests::i32_value ... ok$<2> test tests::i8_value ... ok$<2> test tests::i64_value ... ok$<2> test tests::ip_addr ... ok$<2> test tests::issue_59 ... ok$<2> test tests::issue_99 ... ok$<2> test tests::array_value ... ok$<2> test tests::object_path_value ... ok$<2> test tests::dict_value ... ok$<2> test tests::signature_value ... ok$<2> test tests::serialized_size ... ok$<2> test tests::struct_byte_array ... ok$<2> test tests::struct_ref ... ok$<2> test tests::str_value ... ok$<2> test tests::option_value ... ok$<2> test tests::struct_value ... ok$<2> test tests::struct_with_hashmap ... ok$<2> test tests::u16_value ... ok$<2> test tests::u32_value ... ok$<2> test tests::unit ... ok$<2> test tests::u8_value ... ok$<2> test tests::unit_fds ... ok$<2> test tests::value_value ... ok$<2> test tests::recursion_limits ... ok$<2> test result: ok$<2>. 37 passed; 0 failed; 0 ignored; 0 measured; 0 filtered out; finished in 0.21s root@qemux86-64:~# (From OE-Core rev: 912bbec9fe44f22ab70c3553af6cb699543b8411) Signed-off-by: Frederic Martinsons <frederic.martinsons@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb b/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
index 4285d11b72..36f2a07ecf 100644
--- a/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
+++ b/meta-selftest/recipes-extended/zvariant/zvariant_3.12.0.bb
@@ -7,6 +7,8 @@ HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/"
7LICENSE = "MIT" 7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d"
9 9
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'glib-2.0', '', d)}"
11
10SRC_URI = " \ 12SRC_URI = " \
11 git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \ 13 git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \
12 file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \ 14 file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \
@@ -21,10 +23,15 @@ python do_clean_lic_file_symlink() {
21 23
22addtask clean_lic_file_symlink after do_unpack before do_patch 24addtask clean_lic_file_symlink after do_unpack before do_patch
23 25
24inherit cargo cargo-update-recipe-crates 26inherit ptest-cargo pkgconfig cargo-update-recipe-crates
25 27
26# Remove this when the recipe is reproducible 28# Remove this when the recipe is reproducible
27EXCLUDE_FROM_WORLD = "1" 29EXCLUDE_FROM_WORLD = "1"
28 30
29require ${BPN}-crates.inc 31require ${BPN}-crates.inc
30require ${BPN}-git-crates.inc 32require ${BPN}-git-crates.inc
33
34# zvariant is an indermediate product for the zbus project
35# and so, it provided only a static lib (rlib) which fall only
36# in -dev package
37ALLOW_EMPTY:${PN} = "1"