summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorEilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>2023-12-07 12:45:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-08 17:51:10 +0000
commite3ce7ce2158cff3c4f4f27166fac125d3f664bde (patch)
tree940ed89692b3e2cc655078dc61e2c4f8d06f5be4 /meta-selftest
parentecef665062be55fcfa0915216335d08883aa86f7 (diff)
downloadpoky-e3ce7ce2158cff3c4f4f27166fac125d3f664bde.tar.gz
useradd: Add testcase for bugzilla issue (currently disabled)
Add a disabled a test for 14961 - addtask between do_populate_sysroot and do_package breaks useradd class. A fix is still needed for this. (From OE-Core rev: b6af5788f7f8fb1e9d8ad14bd12168ff9d6baa21) Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/selftest-users/useraddbadtask.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
new file mode 100644
index 0000000000..99e04a80b3
--- /dev/null
+++ b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
@@ -0,0 +1,20 @@
1SUMMARY = "UserAddBadTask"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
3
4LICENSE = "MIT"
5
6DEPENDS:append = "coreutils-native"
7
8S = "${WORKDIR}"
9
10inherit useradd allarch
11
12USERADD_PACKAGES = "${PN}"
13USERADD_PARAM:${PN} = "-u 5555 --gid groupaddtask useraddtask"
14GROUPADD_PARAM:${PN} = "-r groupaddtask"
15
16do_badthingshappen() {
17 echo "foo"
18}
19
20addtask badthingshappen after do_populate_sysroot before do_package