summaryrefslogtreecommitdiffstats
path: root/meta-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-04-19 16:54:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-20 02:18:06 +0100
commitcd5e5860669cd7b41e77bfc21a18b7d779b8ab68 (patch)
tree4ec7890b1a7c0962b37c52daa3ec2509b089ff14 /meta-rt
parentc4371138f7444ecaa1fdd2b1ee4949fbc819f886 (diff)
downloadpoky-cd5e5860669cd7b41e77bfc21a18b7d779b8ab68.tar.gz
kernel-rt: use correct branch names and new git SRC_REV format
The RT kernel recipe was not updated to reflect the new git SRC_REV format nor to take advantage of the recent updates made to the underlying infrastructure. These fixes bring it up to date with the other linux-yocto* recipes and fix various build issues people were seeing. (From OE-Core rev: 690e87a2ffe8caa16379be26eb356c5bded17c1f) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-rt')
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
index 547f8feac3..cba132176a 100644
--- a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
+++ b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
@@ -8,7 +8,10 @@ LINUX_VERSION ?= "2.6.34"
8LINUX_KERNEL_TYPE = "preempt_rt" 8LINUX_KERNEL_TYPE = "preempt_rt"
9LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}" 9LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
10 10
11PR = "r0" 11KMETA = wrs_meta
12KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
13
14PR = "r1"
12PV = "${LINUX_VERSION}+git${SRCPV}" 15PV = "${LINUX_VERSION}+git${SRCPV}"
13SRCREV_FORMAT = "meta_machine" 16SRCREV_FORMAT = "meta_machine"
14 17
@@ -18,16 +21,11 @@ COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)"
18python __anonymous () { 21python __anonymous () {
19 import bb, re, string 22 import bb, re, string
20 23
21 rev = bb.data.getVar("SRCREV_machine", d, 1)
22 if rev == "standard":
23 bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
24
25 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-") 24 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
26 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d) 25 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
27} 26}
28 27
29SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \ 28SRC_URI = "git://git.yoctoproject.org/linux-2.6-windriver.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
30 git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
31 29
32# Functionality flags 30# Functionality flags
33KERNEL_REVISION_CHECKING ?= "t" 31KERNEL_REVISION_CHECKING ?= "t"