summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/uicmoc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-01 20:55:25 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-01 20:55:25 +0000
commitd7aaf31869621480977d0a8f2faee199b83fd699 (patch)
tree116941f8a6f5a7bb81ffc610a5c6218ed8764219 /meta-moblin/packages/uicmoc
parent14ecbd658ead9daa8785bc4fe911ed6a8718c0b9 (diff)
downloadpoky-d7aaf31869621480977d0a8f2faee199b83fd699.tar.gz
meta-moblin: Add basic qt support (from OE)
Diffstat (limited to 'meta-moblin/packages/uicmoc')
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch160
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/no-examples.patch16
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb51
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc4-native.inc62
-rw-r--r--meta-moblin/packages/uicmoc/uicmoc4-native_4.3.2.bb1
5 files changed, 290 insertions, 0 deletions
diff --git a/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch b/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch
new file mode 100644
index 0000000000..0e5d3ff153
--- /dev/null
+++ b/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/64bit-cleanup.patch
@@ -0,0 +1,160 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- qt-embedded-free-3.3.5/src/embedded/qgfxlinuxfb_qws.cpp~64bit-cleanup.patch
7+++ qt-embedded-free-3.3.5/src/embedded/qgfxlinuxfb_qws.cpp
8@@ -40,6 +40,7 @@
9
10 #include <unistd.h>
11 #include <stdlib.h>
12+#include <stdint.h>
13 #include <sys/ioctl.h>
14 #include <sys/types.h>
15 #include <sys/stat.h>
16@@ -176,7 +177,7 @@
17 MAP_SHARED, fd, 0);
18 data += dataoffset;
19
20- if ((int)data == -1) {
21+ if ((intptr_t)data == -1) {
22 perror("mapping /dev/fb0");
23 qWarning("Error: failed to map framebuffer device to memory.");
24 return FALSE;
25@@ -737,7 +738,7 @@
26 psize += 8; // for alignment
27 psize &= ~0x7; // align
28
29- unsigned int pos=(unsigned int)data;
30+ uintptr_t pos=(uintptr_t)data;
31 pos += psize;
32 entryp = ((int *)pos);
33 lowest = ((unsigned int *)pos)+1;
34--- qt-embedded-free-3.3.5/src/kernel/qsharedmemory_p.cpp~64bit-cleanup.patch
35+++ qt-embedded-free-3.3.5/src/kernel/qsharedmemory_p.cpp
36@@ -31,6 +31,7 @@
37 **********************************************************************/
38
39 #include "qsharedmemory_p.h"
40+#include <stdint.h>
41
42 #if !defined(QT_QWS_NO_SHM)
43
44@@ -132,7 +133,7 @@
45 shmId = shmget (key, shmSize, 0);
46
47 shmBase = shmat (shmId, 0, 0);
48- if ((int) shmBase == -1 || shmBase == 0)
49+ if ((intptr_t) shmBase == -1 || shmBase == 0)
50 return FALSE;
51 else
52 return TRUE;
53--- qt-embedded-free-3.3.5/src/kernel/qapplication_qws.cpp~64bit-cleanup.patch
54+++ qt-embedded-free-3.3.5/src/kernel/qapplication_qws.cpp
55@@ -107,6 +107,7 @@
56 #include <locale.h>
57 #include <errno.h>
58 #include <sys/time.h>
59+#include <stdint.h>
60
61 #if defined(Q_OS_QNX)
62 #include <sys/select.h>
63@@ -1879,7 +1880,7 @@
64 w = widgetAt(*qt_last_x, *qt_last_y, FALSE);
65 if ( !w )
66 w = desktop();
67- QPaintDevice::qwsDisplay()->selectCursor(w, (int)app_cursor->handle());
68+ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)app_cursor->handle());
69 }
70
71 void QApplication::restoreOverrideCursor()
72@@ -1898,11 +1899,11 @@
73 cursorStack = 0;
74 qws_overrideCursor = FALSE;
75 if ( w->testWState(WState_OwnCursor) )
76- QPaintDevice::qwsDisplay()->selectCursor(w, (int)w->cursor().handle());
77+ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)w->cursor().handle());
78 else
79 QPaintDevice::qwsDisplay()->selectCursor(w, ArrowCursor);
80 } else {
81- QPaintDevice::qwsDisplay()->selectCursor(w, (int)app_cursor->handle());
82+ QPaintDevice::qwsDisplay()->selectCursor(w, (intptr_t)app_cursor->handle());
83 }
84 }
85 #endif// QT_NO_CURSOR
86@@ -2130,7 +2131,7 @@
87 }
88 if ( !qws_overrideCursor ) {
89 if (curs)
90- QPaintDevice::qwsDisplay()->selectCursor(widget, (int)curs->handle());
91+ QPaintDevice::qwsDisplay()->selectCursor(widget, (intptr_t)curs->handle());
92 else
93 QPaintDevice::qwsDisplay()->selectCursor(widget, ArrowCursor);
94 }
95--- qt-embedded-free-3.3.5/src/kernel/qfont_qws.cpp~64bit-cleanup.patch
96+++ qt-embedded-free-3.3.5/src/kernel/qfont_qws.cpp
97@@ -49,6 +49,7 @@
98 #include "qgfx_qws.h"
99 #include "qtextengine_p.h"
100 #include "qfontengine_p.h"
101+#include <stdint.h>
102
103 QFont::Script QFontPrivate::defaultScript = QFont::UnknownScript;
104
105@@ -133,7 +134,7 @@
106 req.pointSize = req.pixelSize*10;
107
108 if ( ! engineData ) {
109- QFontCache::Key key( req, QFont::NoScript, (int)paintdevice );
110+ QFontCache::Key key( req, QFont::NoScript, (intptr_t)paintdevice );
111
112 // look for the requested font in the engine data cache
113 engineData = QFontCache::instance->findEngineData( key );
114--- qt-embedded-free-3.3.5/src/kernel/qwsregionmanager_qws.cpp~64bit-cleanup.patch
115+++ qt-embedded-free-3.3.5/src/kernel/qwsregionmanager_qws.cpp
116@@ -32,6 +32,7 @@
117 #include "qwsdisplay_qws.h"
118 #include "qwsregionmanager_qws.h"
119 #include <stdlib.h>
120+#include <stdint.h>
121
122 #ifndef QT_NO_QWS_MULTIPROCESS
123 #include <sys/types.h>
124@@ -288,7 +289,7 @@
125 data = (unsigned char *)shmat( shmId, 0, 0 );
126 }
127
128- return ( shmId != -1 && (int)data != -1 );
129+ return ( shmId != -1 && (intptr_t)data != -1 );
130 #else
131 int dataSize = sizeof(QWSRegionHeader) // header
132 + sizeof(QWSRegionIndex) * QT_MAX_REGIONS // + index
133--- qt-embedded-free-3.3.5/src/kernel/qwidget_qws.cpp~64bit-cleanup.patch
134+++ qt-embedded-free-3.3.5/src/kernel/qwidget_qws.cpp
135@@ -53,6 +53,7 @@
136 #include "qwsmanager_qws.h"
137 #include "qwsregionmanager_qws.h"
138 #include "qinputcontext_p.h"
139+#include <stdint.h>
140
141 void qt_insert_sip( QWidget*, int, int ); // defined in qapplication_x11.cpp
142 int qt_sip_count( QWidget* ); // --- "" ---
143@@ -631,7 +632,7 @@
144 qt_mouseGrb->releaseMouse();
145
146 qwsDisplay()->grabMouse(this,TRUE);
147- qwsDisplay()->selectCursor(this, (unsigned int)cursor.handle());
148+ qwsDisplay()->selectCursor(this, (uintptr_t)cursor.handle());
149 qt_mouseGrb = this;
150 qt_pressGrab = 0;
151 }
152@@ -1845,7 +1846,7 @@
153 QSize s( qt_screen->width(), qt_screen->height() );
154 QPoint pos = qt_screen->mapToDevice(QPoint(*qt_last_x, *qt_last_y), s);
155 if ( r.contains(pos) )
156- qwsDisplay()->selectCursor((QWidget*)this, (unsigned int)cursor().handle());
157+ qwsDisplay()->selectCursor((QWidget*)this, (uintptr_t)cursor().handle());
158 }
159 }
160 #endif
diff --git a/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/no-examples.patch b/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/no-examples.patch
new file mode 100644
index 0000000000..b0ee6374ef
--- /dev/null
+++ b/meta-moblin/packages/uicmoc/uicmoc3-native-3.3.5/no-examples.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- qt-embedded-free-3.3.2/Makefile~no-examples 2003-08-11 16:37:25.000000000 +0200
7+++ qt-embedded-free-3.3.2/Makefile 2004-05-11 15:53:53.000000000 +0200
8@@ -11,7 +11,7 @@
9 install: FORCE
10 @$(MAKE) qt.install
11
12-all: symlinks src-qmake src-moc sub-src sub-tools sub-tutorial sub-examples
13+all: symlinks src-qmake src-moc sub-src sub-tools
14 @echo
15 @echo "The Qt library is now built in ./lib"
16 @echo "The Qt examples are built in the directories in ./examples"
diff --git a/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb b/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb
new file mode 100644
index 0000000000..11b0c506dc
--- /dev/null
+++ b/meta-moblin/packages/uicmoc/uicmoc3-native_3.3.5.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 3.x"
2HOMEPAGE = "http://www.trolltech.com"
3SECTION = "devel"
4PRIORITY = "optional"
5LICENSE = "GPL QPL"
6DEPENDS = "qmake-native"
7PR = "r3"
8
9SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2 \
10 file://no-examples.patch;patch=1 \
11 file://64bit-cleanup.patch;patch=1"
12S = "${WORKDIR}/qt-embedded-free-${PV}"
13
14inherit native qmake_base qt3e
15
16export QTDIR = "${S}"
17export OE_QMAKE_LINK="${CXX}"
18CXXFLAGS += " -DQWS"
19
20QT_CONFIG_FLAGS = "-release -static -depths 8,16 -qt-zlib -no-nas-sound \
21 -no-sm -no-libjpeg -no-libmng -no-gif -no-xshape -no-xinerama \
22 -no-xcursor -no-xrandr -no-xrender -no-xft -no-tablet \
23 -no-xkb -no-dlopen-opengl -no-freetype -no-thread \
24 -no-nis -no-cups -prefix ${prefix} \
25 -xplatform ${OE_QMAKE_PLATFORM} \
26 -platform ${OE_QMAKE_PLATFORM}"
27
28do_configure() {
29 oe_qmake_mkspecs
30 echo "yes" | ./configure ${QT_CONFIG_FLAGS}
31}
32
33do_compile() {
34 oe_runmake symlinks || die "Can't symlink include files"
35 oe_runmake src-moc || die "Building moc failed"
36 oe_runmake sub-tools || die "Building tools failed"
37}
38
39do_stage() {
40 install -d ${OE_QMAKE_INCDIR_QT}
41 install -d ${OE_QMAKE_LIBDIR_QT}
42
43 install -m 0755 bin/moc ${OE_QMAKE_MOC}
44 install -m 0755 bin/uic ${OE_QMAKE_UIC}
45 install -m 0655 lib/*.a ${OE_QMAKE_LIBDIR_QT}
46
47 for f in include/*.h
48 do
49 install -m 0644 $f ${OE_QMAKE_INCDIR_QT}/
50 done
51}
diff --git a/meta-moblin/packages/uicmoc/uicmoc4-native.inc b/meta-moblin/packages/uicmoc/uicmoc4-native.inc
new file mode 100644
index 0000000000..8c4787866e
--- /dev/null
+++ b/meta-moblin/packages/uicmoc/uicmoc4-native.inc
@@ -0,0 +1,62 @@
1DESCRIPTION = "User-Interface-, Meta-Object-, and Resource Compiler for Qt/[X11|Mac|Embedded] version 4.x"
2DEPENDS = "zlib-native"
3SECTION = "libs"
4HOMEPAGE = "http://www.trolltech.com"
5PRIORITY = "optional"
6LICENSE = "GPL"
7PR = "r1"
8
9SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz"
10S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
11
12inherit native
13
14EXTRA_OECONF = "-prefix ${STAGING_DIR_NATIVE}/qt4 \
15 -qt-libjpeg -qt-gif -system-zlib \
16 -no-nis -no-cups -no-exceptions \
17 -no-accessibility -no-libjpeg \
18 -no-nas-sound -no-sm \
19 -no-xshape -no-xinerama \
20 -no-xcursor -no-xrandr \
21 -no-xrender -no-fontconfig \
22 -no-tablet -no-xkb \
23 -no-libpng \
24 -verbose -release -fast -static \
25 -L ${STAGING_LIBDIR_NATIVE} \
26 -qt3support "
27# yank default -e
28EXTRA_OEMAKE = " "
29
30do_configure() {
31 sed -i 's:^QT += xml qt3support$:QT += xml qt3support network:' "${S}"/src/tools/uic3/uic3.pro
32 echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
33}
34
35TOBUILD = "\
36 src/tools/moc \
37 src/corelib \
38 src/sql \
39 src/qt3support \
40 src/xml \
41 src/tools/uic \
42 src/tools/rcc \
43 src/network \
44 src/gui \
45 src/tools/uic3 \
46"
47
48do_compile() {
49 unset CC CXX CFLAGS LFLAGS CXXFLAGS CPPFLAGS
50 for i in ${TOBUILD}; do
51 cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
52 done
53}
54
55do_stage() {
56 install -m 0755 bin/moc ${STAGING_BINDIR}/moc4
57 install -m 0755 bin/uic ${STAGING_BINDIR}/uic4
58 install -m 0755 bin/uic3 ${STAGING_BINDIR}/uic34
59 install -m 0755 bin/rcc ${STAGING_BINDIR}/rcc4
60 install -d ${STAGING_DIR_NATIVE}/qt4/
61 install -m 0644 tools/porting/src/q3porting.xml ${STAGING_DIR_NATIVE}/qt4/
62}
diff --git a/meta-moblin/packages/uicmoc/uicmoc4-native_4.3.2.bb b/meta-moblin/packages/uicmoc/uicmoc4-native_4.3.2.bb
new file mode 100644
index 0000000000..1950f63068
--- /dev/null
+++ b/meta-moblin/packages/uicmoc/uicmoc4-native_4.3.2.bb
@@ -0,0 +1 @@
require uicmoc4-native.inc