summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-07 22:15:48 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-07 22:15:48 +0000
commitf3d2ad4fb1262dc95916d9362e14d36daa0c537c (patch)
tree0bd8101d9cec260a5e340aba7e9fe6731bc0bb61 /meta-extras
parent7fed31ddb0a5826d5b22d1476ff31db19cdc48c1 (diff)
downloadpoky-f3d2ad4fb1262dc95916d9362e14d36daa0c537c.tar.gz
iproute2: Move from meta-extras to meta
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3717 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff25
-rw-r--r--meta-extras/packages/iproute2/iproute2-2.6.18/new-flex-fix.patch83
-rw-r--r--meta-extras/packages/iproute2/iproute2.inc18
-rw-r--r--meta-extras/packages/iproute2/iproute2_2.6.18.bb8
4 files changed, 0 insertions, 134 deletions
diff --git a/meta-extras/packages/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff b/meta-extras/packages/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff
deleted file mode 100644
index 496506960e..0000000000
--- a/meta-extras/packages/iproute2/iproute2-2.6.18/iproute2-2.6.15_no_strip.diff
+++ /dev/null
@@ -1,25 +0,0 @@
1--- ip/Makefile 2006/02/23 21:22:18 1.1
2+++ ip/Makefile 2006/02/23 21:22:27
3@@ -16,7 +16,7 @@
4 rtmon: $(RTMONOBJ) $(LIBNETLINK)
5
6 install: all
7- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
8+ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
9 install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
10
11 clean:
12--- tc/Makefile 2006/02/23 21:23:52 1.1
13+++ tc/Makefile 2006/02/23 21:23:57
14@@ -70,9 +70,9 @@
15
16 install: all
17 mkdir -p $(DESTDIR)/usr/lib/tc
18- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
19+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
20 for i in $(TCSO); \
21- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
22+ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
23 done
24
25 clean:
diff --git a/meta-extras/packages/iproute2/iproute2-2.6.18/new-flex-fix.patch b/meta-extras/packages/iproute2/iproute2-2.6.18/new-flex-fix.patch
deleted file mode 100644
index 2c04087839..0000000000
--- a/meta-extras/packages/iproute2/iproute2-2.6.18/new-flex-fix.patch
+++ /dev/null
@@ -1,83 +0,0 @@
1The tc command was failing to build due to flex errors. These errors are
2caused by an incompatible change to flex in recent versions, including the
3version shipped with OE.
4
5This fix is as per the one used by opensure:
6
7 http://lists.opensuse.org/opensuse-commit/2006-04/msg00090.html
8
9and simple renames str to prevent it conflicting.
10
11--- iproute2-2.6.16-060323/tc/emp_ematch.l 2006/10/30 22:46:29 1.1
12+++ iproute2-2.6.16-060323/tc/emp_ematch.l 2006/10/30 22:47:26
13@@ -63,7 +63,7 @@
14
15 %}
16
17-%x str
18+%x STR
19
20 %option 8bit stack warn noyywrap prefix="ematch_"
21 %%
22@@ -78,17 +78,17 @@
23 }
24 strbuf_index = 0;
25
26- BEGIN(str);
27+ BEGIN(STR);
28 }
29
30-<str>\" {
31+<STR>\" {
32 BEGIN(INITIAL);
33 yylval.b = bstr_new(strbuf, strbuf_index);
34 yylval.b->quoted = 1;
35 return ATTRIBUTE;
36 }
37
38-<str>\\[0-7]{1,3} { /* octal escape sequence */
39+<STR>\\[0-7]{1,3} { /* octal escape sequence */
40 int res;
41
42 sscanf(yytext + 1, "%o", &res);
43@@ -100,12 +100,12 @@
44 strbuf_append_char((unsigned char) res);
45 }
46
47-<str>\\[0-9]+ { /* catch wrong octal escape seq. */
48+<STR>\\[0-9]+ { /* catch wrong octal escape seq. */
49 fprintf(stderr, "error: invalid octale escape sequence\n");
50 return ERROR;
51 }
52
53-<str>\\x[0-9a-fA-F]{1,2} {
54+<STR>\\x[0-9a-fA-F]{1,2} {
55 int res;
56
57 sscanf(yytext + 2, "%x", &res);
58@@ -118,16 +118,16 @@
59 strbuf_append_char((unsigned char) res);
60 }
61
62-<str>\\n strbuf_append_char('\n');
63-<str>\\r strbuf_append_char('\r');
64-<str>\\t strbuf_append_char('\t');
65-<str>\\v strbuf_append_char('\v');
66-<str>\\b strbuf_append_char('\b');
67-<str>\\f strbuf_append_char('\f');
68-<str>\\a strbuf_append_char('\a');
69+<STR>\\n strbuf_append_char('\n');
70+<STR>\\r strbuf_append_char('\r');
71+<STR>\\t strbuf_append_char('\t');
72+<STR>\\v strbuf_append_char('\v');
73+<STR>\\b strbuf_append_char('\b');
74+<STR>\\f strbuf_append_char('\f');
75+<STR>\\a strbuf_append_char('\a');
76
77-<str>\\(.|\n) strbuf_append_char(yytext[1]);
78-<str>[^\\\n\"]+ strbuf_append_charp(yytext);
79+<STR>\\(.|\n) strbuf_append_char(yytext[1]);
80+<STR>[^\\\n\"]+ strbuf_append_charp(yytext);
81
82 [aA][nN][dD] return AND;
83 [oO][rR] return OR;
diff --git a/meta-extras/packages/iproute2/iproute2.inc b/meta-extras/packages/iproute2/iproute2.inc
deleted file mode 100644
index 006b27b60f..0000000000
--- a/meta-extras/packages/iproute2/iproute2.inc
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "kernel routing and traffic control utilities"
2SECTION = "base"
3LICENSE = "GPL"
4DEPENDS = "flex-native bison-native"
5
6# Set DATE in the .bb file
7SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
8
9S = "${WORKDIR}/${P}-${DATE}"
10
11EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin"
12
13do_install () {
14 oe_runmake DESTDIR=${D} install
15}
16
17FILES_${PN} += "/usr/lib/tc/*"
18FILES_${PN}-dbg += "/usr/lib/tc/.debug"
diff --git a/meta-extras/packages/iproute2/iproute2_2.6.18.bb b/meta-extras/packages/iproute2/iproute2_2.6.18.bb
deleted file mode 100644
index 72eb39d69d..0000000000
--- a/meta-extras/packages/iproute2/iproute2_2.6.18.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1PR = "r1"
2
3require iproute2.inc
4
5SRC_URI += "file://iproute2-2.6.15_no_strip.diff;patch=1;pnum=0 \
6 file://new-flex-fix.patch;patch=1"
7
8DATE = "061002"