summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/libmad
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta-extras/packages/libmad
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/libmad')
-rw-r--r--meta-extras/packages/libmad/libmad_0.15.0b.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-extras/packages/libmad/libmad_0.15.0b.bb b/meta-extras/packages/libmad/libmad_0.15.0b.bb
new file mode 100644
index 0000000000..b3614db05a
--- /dev/null
+++ b/meta-extras/packages/libmad/libmad_0.15.0b.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "MPEG Audio Decoder Library"
2SECTION = "libs"
3PRIORITY = "optional"
4MAINTAINER = "Greg Gilbert <greg@treke.net>"
5DEPENDS = "libid3tag"
6LICENSE = "GPL"
7PR = "r2"
8
9SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
10S = "${WORKDIR}/libmad-${PV}"
11
12inherit autotools
13
14EXTRA_OECONF = "-enable-speed --enable-shared"
15# The ASO's don't take any account of thumb...
16EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
17
18do_configure_prepend () {
19# damn picky automake...
20 touch NEWS AUTHORS ChangeLog
21}
22
23do_stage() {
24 oe_libinstall -so libmad ${STAGING_LIBDIR}
25 install -m 0644 mad.h ${STAGING_INCDIR}
26}