summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/bash/bash_3.2.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-01-21 21:07:52 +0000
committerRoss Burton <ross@openedhand.com>2007-01-21 21:07:52 +0000
commit02ee3a2571de39b6d4c8c85ef290951e6ee1a75f (patch)
tree72c3cac93435d5f0b2dd11a495b8a5426a745079 /meta-extras/packages/bash/bash_3.2.bb
parent7f164499c9b26204bccaba66e3d2a7e4377e1ee1 (diff)
downloadpoky-02ee3a2571de39b6d4c8c85ef290951e6ee1a75f.tar.gz
Add bash for dhcp-client (hopefully temporarily)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1185 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/bash/bash_3.2.bb')
-rw-r--r--meta-extras/packages/bash/bash_3.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-extras/packages/bash/bash_3.2.bb b/meta-extras/packages/bash/bash_3.2.bb
new file mode 100644
index 0000000000..e3d6b0560c
--- /dev/null
+++ b/meta-extras/packages/bash/bash_3.2.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "An sh-compatible command language interpreter."
2HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
3DEPENDS = "ncurses"
4SECTION = "base/shell"
5LICENSE = "GPL"
6
7SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
8 file://001-005.patch;patch=1"
9
10inherit autotools gettext
11
12PARALLEL_MAKE = ""
13
14bindir = "/bin"
15sbindir = "/sbin"
16
17EXTRA_OECONF = "--with-ncurses"
18export CC_FOR_BUILD = "${BUILD_CC}"
19
20do_configure () {
21 gnu-configize
22 oe_runconf
23}
24
25pkg_postinst () {
26 grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
27 grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
28}