summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-gnome/abiword/abiword.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-08 14:25:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-08 14:49:16 +0100
commit67f6baa72a2c4ab868ec9c333863476e4e77513a (patch)
tree00b72871d7f12e556eb98c67c1a0b3b0c94c3871 /meta-demoapps/recipes-gnome/abiword/abiword.inc
parent71e56f8d89c05859ddb817731653d39a8145fb98 (diff)
downloadpoky-67f6baa72a2c4ab868ec9c333863476e4e77513a.tar.gz
meta-demoapps: Remove except for xeyes and pong-clock
http://lists.linuxtogo.org/pipermail/openembedded-core/2012-May/022059.html As proposed by Martin Jansa with a couple of changes from me. (From OE-Core rev: 204ee7391c19f9b2fa7f8b2ef46d04c7ccf5bd42) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-demoapps/recipes-gnome/abiword/abiword.inc')
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword.inc64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword.inc b/meta-demoapps/recipes-gnome/abiword/abiword.inc
deleted file mode 100644
index 036f98f348..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword.inc
+++ /dev/null
@@ -1,64 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2SECTION = "gnome/office"
3HOMEPAGE = "http://www.abiword.org""
4LICENSE = "GPLv2"
5
6DEPENDS = "libgsf libglade libfribidi libxml2 wv"
7RRECOMMENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9
10# Share this file between recipes that use cvs and that pull tarballs
11# (one day change this to differentiate automatically based on PV and set the
12# SRC_URI and S var directly)
13RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
14RELSRC = "${WORKDIR}/abiword-${PV}/abi"
15
16SVNURI = "svn://svn.abisource.com/abiword/trunk;module=abiword;proto=http"
17SVNSRC = "${WORKDIR}/abi"
18
19#want 2.x from 2.x.y for the installation directory
20SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
21
22FILES_${PN} += " \
23 ${datadir}/icons/* \
24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28 "
29
30# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
31# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
32
33inherit autotools pkgconfig
34
35PARALLEL_MAKE = ""
36
37# This is a minimalistic AbiWord build
38#
39# if you are planning to build plugins, make sure to comment out the
40# --disable-exports options
41
42EXTRA_OECONF = " --enable-embedded=poky \
43 --disable-printing \
44 --with-sys-wv \
45 --disable-exports \
46 --disable-spellcheck"
47
48# TODO -- refactor this, so that instead of two strings and profiles
49# packages we have lots of locale packages, each with a set of strings and
50# a profile
51#
52PACKAGES += " abiword-strings abiword-systemprofiles"
53
54FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
55FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
56
57# AbiWord configure.ac does not play nicely with autoreconf
58# so use the autogen.sh script that comes with AbiWord
59#
60do_configure() {
61 cd ${S}
62 export NOCONFIGURE="no"; ./autogen.sh
63 oe_runconf
64}