summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb')
-rw-r--r--meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb b/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
new file mode 100644
index 0000000000..022f709f99
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
@@ -0,0 +1,37 @@
1SECTION = "console/network"
2SUMMARY = "IPsec implementation"
3DESCRIPTION = "Openswan is an Open Source implementation of IPsec for the \
4Linux operating system."
5HOMEPAGE = "http://www.openswan.org"
6LICENSE = "GPLv2"
7DEPENDS = "gmp flex-native"
8RRECOMMENDS = "kernel-module-ipsec"
9RDEPENDS_nylon = "perl"
10PR = "r0"
11
12SRC_URI = "http://www.openswan.org/download/old/openswan-${PV}.tar.gz \
13 file://openswan-2.4.7-gentoo.patch;patch=1 \
14 file://installflags.patch;patch=1 \
15 file://ld-library-path-breakage.patch;patch=1"
16S = "${WORKDIR}/openswan-${PV}"
17
18PARALLEL_MAKE = ""
19EXTRA_OEMAKE = "DESTDIR=${D} \
20 USERCOMPILE="${CFLAGS}" \
21 FINALCONFDIR=${sysconfdir}/ipsec \
22 INC_RCDEFAULT=${sysconfdir}/init.d \
23 INC_USRLOCAL=${prefix} \
24 INC_MANDIR=share/man WERROR=''"
25
26do_compile () {
27 oe_runmake programs
28}
29
30do_install () {
31 oe_runmake install
32}
33
34FILES_${PN} = "${sysconfdir} ${libdir}/ipsec/* ${sbindir}/* ${libexecdir}/ipsec/*"
35FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"
36
37CONFFILES_${PN} = "${sysconfdir}/ipsec/ipsec.conf"