summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb b/meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb
new file mode 100644
index 00000000..04ae540d
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/librfclk/librfclk_2023.1.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux rfclk library"
2SECTION = "librfclk"
3
4inherit pkgconfig xlnx-embeddedsw features_check
5
6REQUIRED_MACHINE_FEATURES = "rfsoc"
7
8FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
9
10S = "${WORKDIR}/git"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14PROVIDES = "librfclk"
15
16RFCLK_SUBDIR = "XilinxProcessorIPLib/drivers/board_common/src/rfclk/src"
17
18do_compile:prepend() {
19 cd ${S}/${RFCLK_SUBDIR}
20 cp Makefile.Linux Makefile
21}
22
23do_install() {
24 install -d ${D}${libdir}
25 install -d ${D}${includedir}
26
27 cd ${S}/${RFCLK_SUBDIR}
28 oe_libinstall -so librfclk ${D}${libdir}
29 install -m 0644 xrfclk.h ${D}${includedir}/xrfclk.h
30 install -m 0644 xrfclk_LMK_conf.h ${D}${includedir}/xrfclk_LMK_conf.h
31 install -m 0644 xrfclk_LMX_conf.h ${D}${includedir}/xrfclk_LMX_conf.h
32}
33
34FILES:${PN} = "${libdir}/*.so.*"
35FILES:${PN}-dev = "${libdir}/*.so ${includedir}/*"