diff options
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/libdfeccf/libdfeccf_2023.2.bb')
-rw-r--r-- | meta-xilinx-standalone/recipes-bsp/libdfeccf/libdfeccf_2023.2.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/libdfeccf/libdfeccf_2023.2.bb b/meta-xilinx-standalone/recipes-bsp/libdfeccf/libdfeccf_2023.2.bb new file mode 100644 index 00000000..04415f5e --- /dev/null +++ b/meta-xilinx-standalone/recipes-bsp/libdfeccf/libdfeccf_2023.2.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "Linux dfeccf library" | ||
2 | SECTION = "libdfeccf" | ||
3 | LICENSE = "BSD" | ||
4 | |||
5 | inherit pkgconfig xlnx-embeddedsw features_check | ||
6 | |||
7 | REQUIRED_MACHINE_FEATURES = "rfsoc" | ||
8 | |||
9 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | DEPENDS = "libmetal" | ||
16 | |||
17 | PROVIDES = "libdfeccf" | ||
18 | |||
19 | DFECCF_SUBDIR = "XilinxProcessorIPLib/drivers/dfeccf/src" | ||
20 | |||
21 | do_compile:prepend() { | ||
22 | cd ${S}/${DFECCF_SUBDIR} | ||
23 | cp Makefile.Linux Makefile | ||
24 | } | ||
25 | |||
26 | do_install() { | ||
27 | install -d ${D}${libdir} | ||
28 | install -d ${D}${includedir} | ||
29 | |||
30 | cd ${S}/${DFECCF_SUBDIR} | ||
31 | oe_libinstall -so libdfeccf ${D}${libdir} | ||
32 | install -m 0644 xdfeccf_hw.h ${D}${includedir}/xdfeccf_hw.h | ||
33 | install -m 0644 xdfeccf.h ${D}${includedir}/xdfeccf.h | ||
34 | } | ||
35 | |||
36 | FILES:${PN} = "${libdir}/*.so.*" | ||
37 | FILES:${PN}-dev = "${libdir}/*.so ${includedir}/*" | ||