diff options
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend')
-rw-r--r-- | meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend new file mode 100644 index 00000000..8944152d --- /dev/null +++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend | |||
@@ -0,0 +1,17 @@ | |||
1 | # Include the versal-fw setting, if it's enabled | ||
2 | PSMFW_INC = "${@bb.utils.contains('BBMULTICONFIG', 'versal-fw', 'versal-fw-cfg.inc', '', d)}" | ||
3 | require ${PSMFW_INC} | ||
4 | |||
5 | def check_psm_vars(d): | ||
6 | if not d.getVar('PSM_DEPENDS') and not d.getVar('PSM_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'versal-fw' in d.getVar('BBMULTICONFIG').split()): | ||
7 | msg = "" | ||
8 | fail = False | ||
9 | if not os.path.exists(d.getVar('PSM_FILE') + ".elf"): | ||
10 | msg = msg + "The expected file %s.elf is not available. " % d.getVar('PSM_FILE') | ||
11 | fail = True | ||
12 | if not os.path.exists(d.getVar('PSM_FILE') + ".bin"): | ||
13 | msg = msg + "The expected file %s.bin is not available. " % d.getVar('PSM_FILE') | ||
14 | fail = True | ||
15 | if fail: | ||
16 | d.setVar('BB_DONT_CACHE', '1') | ||
17 | raise bb.parse.SkipRecipe("%s\nEither specify PSM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg) | ||