summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc40
1 files changed, 21 insertions, 19 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
index ed3ac959..92dc3cd3 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
@@ -14,11 +14,11 @@ B = "${S}/lib/sw_apps/zynqmp_pmufw/src"
14# The makefile does not handle parallelization 14# The makefile does not handle parallelization
15PARALLEL_MAKE = "-j1" 15PARALLEL_MAKE = "-j1"
16 16
17do_configure() { 17#do_configure:prepend() {
18 # manually do the copy_bsp step first, so as to be able to fix up use of 18# # manually do the copy_bsp step first, so as to be able to fix up use of
19 # mb-* commands 19# # mb-* commands
20 ${B}/../misc/copy_bsp.sh 20# ${B}/../misc/copy_bsp.sh
21} 21#}
22 22
23# All do_compiles need this, even if it's overriden 23# All do_compiles need this, even if it's overriden
24MB_OBJCOPY ??= "${OBJCOPY}" 24MB_OBJCOPY ??= "${OBJCOPY}"
@@ -40,20 +40,22 @@ def bsp_make_vars(d):
40 40
41EXTRA_OEMAKE = "${@bsp_make_vars(d)}" 41EXTRA_OEMAKE = "${@bsp_make_vars(d)}"
42 42
43do_compile() { 43#do_compile() {
44 # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc 44# # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc
45 # properly. So do its job manually. Preparing the includes first, then libs. 45# # properly. So do its job manually. Preparing the includes first, then libs.
46 for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do 46# #for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
47 oe_runmake -C $(dirname $i) -s include 47# # oe_runmake -C $(dirname $i) -s include
48 done 48# #done
49 for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do 49# #for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
50 oe_runmake -C $(dirname $i) -s libs 50# # oe_runmake -C $(dirname $i) -s libs
51 done 51# #done
52 52#
53 # --build-id=none is required due to linker script not defining a location for it. 53# # --build-id=none is required due to linker script not defining a location for it.
54 # Again, recipe-systoot include is necessary 54# # Again, recipe-systoot include is necessary
55 oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" 55# oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
56 56#}
57
58do_compile:append() {
57 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 59 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
58} 60}
59 61