diff options
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2021.2.bb')
-rw-r--r-- | meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2021.2.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2021.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2021.2.bb new file mode 100644 index 00000000..10dc9012 --- /dev/null +++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2021.2.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | require plm-firmware.inc | ||
2 | |||
3 | FILESPATH .= ":${FILE_DIRNAME}/embeddedsw" | ||
4 | |||
5 | SRC_URI += " \ | ||
6 | file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ | ||
7 | file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ | ||
8 | file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \ | ||
9 | file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \ | ||
10 | file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \ | ||
11 | file://zynqmp_pmufw-fixup.patch \ | ||
12 | file://makefile-skip-copy_bsp.sh.patch \ | ||
13 | " | ||
14 | |||
15 | do_configure() { | ||
16 | # manually do the copy_bsp step first, so as to be able to fix up use of | ||
17 | # mb-* commands | ||
18 | . ${B}/../misc/copy_bsp.sh | ||
19 | echo "$BSP_SEQUENTIAL_MAKEFILES" > ${B}/seq.mak | ||
20 | } | ||
21 | |||
22 | do_compile() { | ||
23 | # First process the sequential items | ||
24 | for i in $(cat seq.mak); do | ||
25 | echo Include Seq: $i | ||
26 | if [ ! -d $i ]; then | ||
27 | echo "Skipping...." | ||
28 | continue | ||
29 | fi | ||
30 | oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)} | ||
31 | done | ||
32 | for i in $(cat seq.mak); do | ||
33 | echo Libs Seq: $i | ||
34 | if [ ! -d $i ]; then | ||
35 | echo "Skipping...." | ||
36 | continue | ||
37 | fi | ||
38 | oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)} | ||
39 | done | ||
40 | |||
41 | # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc | ||
42 | # properly. So do its job manually. Preparing the includes first, then libs. | ||
43 | for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do | ||
44 | echo Include: $i | ||
45 | oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)} | ||
46 | done | ||
47 | for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do | ||
48 | echo Libs: $i | ||
49 | oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)} | ||
50 | done | ||
51 | |||
52 | # --build-id=none is required due to linker script not defining a location for it. | ||
53 | # Again, recipe-systoot include is necessary | ||
54 | echo Construct: executable | ||
55 | oe_runmake plm.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" | ||
56 | |||
57 | ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin | ||
58 | } | ||