summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch
new file mode 100644
index 00000000..4ce521cd
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2023.2/makefile-skip-copy_bsp.sh.patch
@@ -0,0 +1,99 @@
1From d703670357546d9aab66baea1f6751ba1cbdf7ad Mon Sep 17 00:00:00 2001
2From: Mark Hatle <mark.hatle@amd.com>
3Date: Wed, 7 Dec 2022 15:30:23 -0800
4Subject: [PATCH] Prevent makefile from calling copy_bsp.sh
5
6If we call copy_bsp.sh we will undo any manual compliation steps we
7have already done. Avoid this.
8
9YP integration specific
10
11Signed-off-by: Mark Hatle <mark.hatle@amd.com>
12---
13 lib/sw_apps/versal_plm/src/versal/Makefile | 4 ++--
14 lib/sw_apps/versal_plm/src/versal_net/Makefile | 4 ++--
15 lib/sw_apps/versal_psmfw/src/versal/Makefile | 4 ++--
16 lib/sw_apps/versal_psmfw/src/versal_net/Makefile | 6 +++---
17 lib/sw_apps/zynqmp_pmufw/src/Makefile | 4 ++--
18 5 files changed, 11 insertions(+), 11 deletions(-)
19
20Index: git/lib/sw_apps/versal_plm/src/versal/Makefile
21===================================================================
22--- git.orig/lib/sw_apps/versal_plm/src/versal/Makefile
23+++ git/lib/sw_apps/versal_plm/src/versal/Makefile
24@@ -35,8 +35,8 @@ $(EXEC): $(LIBS) $(OBJS) $(INCLUDES)
25 $(OBJS): $(LIBS)
26
27 $(LIBS):
28- echo "Copying BSP files"
29- ../../misc/versal/copy_bsp.sh
30+ #echo "Copying BSP files"
31+ #../../misc/versal/copy_bsp.sh
32 echo "Compiling bsp"
33 $(MAKE) -C ../../misc/versal/versal_plm_bsp
34
35Index: git/lib/sw_apps/versal_plm/src/versal_net/Makefile
36===================================================================
37--- git.orig/lib/sw_apps/versal_plm/src/versal_net/Makefile
38+++ git/lib/sw_apps/versal_plm/src/versal_net/Makefile
39@@ -35,8 +35,8 @@ $(EXEC): $(LIBS) $(OBJS) $(INCLUDES)
40 $(OBJS): $(LIBS)
41
42 $(LIBS):
43- echo "Copying BSP files"
44- ../../misc/versal_net/copy_bsp.sh
45+ #echo "Copying BSP files"
46+ #../../misc/versal_net/copy_bsp.sh
47 echo "Compiling bsp"
48 $(MAKE) -C ../../misc/versal_net/versal_plm_bsp
49
50Index: git/lib/sw_apps/versal_psmfw/src/versal/Makefile
51===================================================================
52--- git.orig/lib/sw_apps/versal_psmfw/src/versal/Makefile
53+++ git/lib/sw_apps/versal_psmfw/src/versal/Makefile
54@@ -37,8 +37,8 @@ $(EXEC): $(LIBS) $(OBJS) $(INCLUDES)
55 $(OBJS): $(LIBS)
56
57 $(LIBS):
58- echo "Copying BSP files"
59- ../../misc/copy_bsp.sh
60+ #echo "Copying BSP files"
61+ #../../misc/copy_bsp.sh
62 echo "Compiling bsp"
63 $(MAKE) -C ../../misc/versal_psmfw_bsp
64
65Index: git/lib/sw_apps/versal_psmfw/src/versal_net/Makefile
66===================================================================
67--- git.orig/lib/sw_apps/versal_psmfw/src/versal_net/Makefile
68+++ git/lib/sw_apps/versal_psmfw/src/versal_net/Makefile
69@@ -37,8 +37,8 @@ $(EXEC): $(LIBS) $(OBJS) $(INCLUDES)
70 $(OBJS): $(LIBS)
71
72 $(LIBS):
73- echo "Copying BSP files"
74- ../../misc/versal_net/copy_bsp.sh
75+ #echo "Copying BSP files"
76+ #../../misc/versal_net/copy_bsp.sh
77 echo "Compiling bsp"
78 $(MAKE) -C ../../misc/versal_net/versal_psmfw_bsp
79
80@@ -47,4 +47,3 @@ $(LIBS):
81
82 clean:
83 rm -rf $(OBJS) $(LIBS) $(EXEC) *.o *.d ../common/*.o ../common/*.d
84- rm -rf ../../misc/versal_net/versal_psmfw_bsp
85Index: git/lib/sw_apps/zynqmp_pmufw/src/Makefile
86===================================================================
87--- git.orig/lib/sw_apps/zynqmp_pmufw/src/Makefile
88+++ git/lib/sw_apps/zynqmp_pmufw/src/Makefile
89@@ -30,8 +30,8 @@ $(EXEC): $(LIBS) $(OBJS) $(INCLUDES)
90 $(OBJS): $(LIBS)
91
92 $(LIBS):
93- echo "Copying BSP files"
94- ../misc/copy_bsp.sh
95+ #echo "Copying BSP files"
96+ #../misc/copy_bsp.sh
97 echo "Compiling bsp"
98 $(MAKE) -C ../misc/zynqmp_pmufw_bsp
99