diff options
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-libraries/xilstandalone_2024.2.bb')
-rw-r--r-- | meta-xilinx-standalone-sdt/recipes-libraries/xilstandalone_2024.2.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-libraries/xilstandalone_2024.2.bb b/meta-xilinx-standalone-sdt/recipes-libraries/xilstandalone_2024.2.bb new file mode 100644 index 00000000..a4b0037b --- /dev/null +++ b/meta-xilinx-standalone-sdt/recipes-libraries/xilstandalone_2024.2.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | inherit esw python3native | ||
2 | |||
3 | ESW_COMPONENT_SRC = "/lib/bsp/standalone/src/" | ||
4 | ESW_COMPONENT_NAME = "libxilstandalone.a" | ||
5 | |||
6 | DEPENDS += "libgloss" | ||
7 | |||
8 | do_configure:prepend() { | ||
9 | # This script should also not rely on relative paths and such | ||
10 | ( | ||
11 | cd ${S} | ||
12 | lopper ${DTS_FILE} -- baremetal_bspconfig_xlnx ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} | ||
13 | install -m 0755 MemConfig.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
14 | install -m 0755 *.c ${S}/${ESW_COMPONENT_SRC} | ||
15 | lopper ${DTS_FILE} -- bmcmake_metadata_xlnx ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S} | ||
16 | install -m 0755 StandaloneExample.cmake ${S}/${ESW_COMPONENT_SRC}/common/ | ||
17 | LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetal_xparameters_xlnx.py ${ESW_MACHINE} ${S} | ||
18 | install -m 0755 xparameters.h ${S}/${ESW_COMPONENT_SRC}/common/ | ||
19 | ) | ||
20 | |||
21 | } | ||