summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb')
-rw-r--r--meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb b/meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb
new file mode 100644
index 00000000..a42d6fd2
--- /dev/null
+++ b/meta-xilinx-standalone-sdt/recipes-libraries/xilskey-example_2024.1.bb
@@ -0,0 +1,29 @@
1inherit esw deploy
2
3ESW_COMPONENT_SRC = "/lib/sw_services/xilskey/examples/"
4
5DEPENDS += "xilskey xilsecure"
6
7do_configure:prepend() {
8 (
9 cd ${S}
10 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
12 )
13}
14
15ESW_CUSTOM_LINKER_FILE ?= "None"
16EXTRA_OECMAKE = "-DCUSTOM_LINKER_FILE=${@d.getVar('ESW_CUSTOM_LINKER_FILE')}"
17
18do_install() {
19 install -d ${D}/${base_libdir}/firmware
20 install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware
21}
22
23do_deploy() {
24 install -d ${DEPLOYDIR}/${BPN}/
25 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${BPN}/
26}
27addtask deploy before do_build after do_package
28
29FILES:${PN} = "${base_libdir}/firmware/*.elf"