diff options
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-libraries/xilnvm-example_2024.2.bb')
-rw-r--r-- | meta-xilinx-standalone-sdt/recipes-libraries/xilnvm-example_2024.2.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-libraries/xilnvm-example_2024.2.bb b/meta-xilinx-standalone-sdt/recipes-libraries/xilnvm-example_2024.2.bb new file mode 100644 index 00000000..bd001f64 --- /dev/null +++ b/meta-xilinx-standalone-sdt/recipes-libraries/xilnvm-example_2024.2.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | inherit esw deploy | ||
2 | |||
3 | ESW_COMPONENT_SRC = "/lib/sw_services/xilnvm/examples/" | ||
4 | |||
5 | PACKAGECONFIG ??= "client server" | ||
6 | PACKAGECONFIG[client] ="-DXILNVM_mode="client",," | ||
7 | PACKAGECONFIG[server] ="-DXILNVM_mode="server",," | ||
8 | |||
9 | DEPENDS += "xilnvm" | ||
10 | |||
11 | do_configure:prepend() { | ||
12 | ( | ||
13 | cd ${S} | ||
14 | lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} | ||
15 | install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
16 | ) | ||
17 | } | ||
18 | |||
19 | ESW_CUSTOM_LINKER_FILE ?= "None" | ||
20 | EXTRA_OECMAKE = "-DCUSTOM_LINKER_FILE=${@d.getVar('ESW_CUSTOM_LINKER_FILE')}" | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}/${base_libdir}/firmware | ||
24 | install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware | ||
25 | } | ||
26 | |||
27 | do_deploy() { | ||
28 | install -d ${DEPLOYDIR}/${BPN}/ | ||
29 | install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${BPN}/ | ||
30 | } | ||
31 | addtask deploy before do_build after do_package | ||
32 | |||
33 | FILES:${PN} = "${base_libdir}/firmware/*.elf" | ||