summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb')
-rw-r--r--meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb b/meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb
new file mode 100644
index 00000000..518b24c3
--- /dev/null
+++ b/meta-xilinx-standalone-sdt/recipes-libraries/xilmailbox-example_2024.1.bb
@@ -0,0 +1,38 @@
1inherit esw deploy
2
3ESW_COMPONENT_SRC = "/lib/sw_services/xilmailbox/examples/"
4
5DEPENDS += "xilmailbox"
6
7do_configure:prepend() {
8 (
9 cd ${S}
10 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
12 )
13}
14
15ESW_CUSTOM_LINKER_FILE ?= "None"
16EXTRA_OECMAKE = "-DCUSTOM_LINKER_FILE=${@d.getVar('ESW_CUSTOM_LINKER_FILE')}"
17
18do_generate_eglist () {
19 cd ${S}
20 lopper ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
21 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
22}
23
24addtask generate_eglist before do_configure after do_prepare_recipe_sysroot
25do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
26
27do_install() {
28 install -d ${D}/${base_libdir}/firmware
29 install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware
30}
31
32do_deploy() {
33 install -d ${DEPLOYDIR}/${BPN}/
34 install -Dm 0644 ${UNPACKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${BPN}/
35}
36addtask deploy before do_build after do_package
37
38FILES:${PN} = "${base_libdir}/firmware/*.elf"