summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb')
-rw-r--r--meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb b/meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb
new file mode 100644
index 00000000..0cef7d97
--- /dev/null
+++ b/meta-xilinx-standalone-sdt/recipes-libraries/xilffs-example_2024.1.bb
@@ -0,0 +1,32 @@
1inherit esw deploy
2
3# Requires by dependency xilffs
4REQUIRED_MACHINE_FEATURES = "sdps"
5
6ESW_COMPONENT_SRC = "/lib/sw_services/xilffs/examples/"
7
8DEPENDS += "xilffs xiltimer"
9
10do_configure:prepend() {
11 (
12 cd ${S}
13 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
15 )
16}
17
18ESW_CUSTOM_LINKER_FILE ?= "None"
19EXTRA_OECMAKE = "-DCUSTOM_LINKER_FILE=${@d.getVar('ESW_CUSTOM_LINKER_FILE')}"
20
21do_install() {
22 install -d ${D}/${base_libdir}/firmware
23 install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware
24}
25
26do_deploy() {
27 install -d ${DEPLOYDIR}/${BPN}/
28 install -Dm 0644 ${UNPACKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${BPN}/
29}
30addtask deploy before do_build after do_package
31
32FILES:${PN} = "${base_libdir}/firmware/*.elf"