diff options
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_2024.2.bb')
-rw-r--r-- | meta-xilinx-standalone-sdt/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_2024.2.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_2024.2.bb b/meta-xilinx-standalone-sdt/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_2024.2.bb new file mode 100644 index 00000000..58d5b9c7 --- /dev/null +++ b/meta-xilinx-standalone-sdt/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_2024.2.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | inherit esw python3native esw_apps_common | ||
2 | |||
3 | ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_echo_server/src/" | ||
4 | |||
5 | DEPENDS += "libxil lwip xiltimer freertos10-xilinx" | ||
6 | |||
7 | ESW_EXECUTABLE_NAME = "freertos_lwip_echo_server" | ||
8 | |||
9 | do_configure:prepend() { | ||
10 | ( | ||
11 | cd ${S} | ||
12 | lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} | ||
13 | install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC} | ||
14 | install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
15 | cp -rf ${S}/scripts/linker_files/ ${S}/${ESW_COMPONENT_SRC}/linker_files | ||
16 | ) | ||
17 | } | ||
18 | |||
19 | do_generate_app_data() { | ||
20 | # This script should also not rely on relative paths and such | ||
21 | cd ${S} | ||
22 | lopper ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S} | ||
23 | install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
24 | } | ||
25 | addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot | ||
26 | do_prepare_recipe_sysroot[rdeptask] = "do_unpack" | ||
27 | |||
28 | FILES:${PN} = "${base_libdir}/firmware/freertos_lwip_echo*" | ||