summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb')
-rw-r--r--meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb b/meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb
new file mode 100644
index 00000000..045b88d5
--- /dev/null
+++ b/meta-xilinx-demos/recipes-firmware/vek280-pl-bram-uart-gpio-fw/vek280-pl-bram-uart-gpio-fw_1.0-2024.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "VEK280 Segemented Configuration(DFx Full) firmware using dfx_user_dts bbclass"
2DESCRIPTION = "VEK280 Segemented Configuration(DFx Full) PL AXI BRAM, AXI GPIO and AXI UART firmware application"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6inherit dfx_user_dts
7
8SRC_URI = "https://petalinux.xilinx.com/sswreleases/rel-v2024.2/sdt/2024.2/2024.2_1106_1_11061206/external/vek280-pl-bram-gpio-fw/vek280-pl-bram-gpio-fw_2024.2_1106_1.tar.gz"
9
10SRC_URI[sha256sum] = "bf7688694a27a0f81e7d59d16c2b819994aa5fb8adfb0d94656da4040e4bc279"
11
12COMPATIBLE_MACHINE:versal-vek280-sdt-seg = "${MACHINE}"
13COMPATIBLE_MACHINE:versal-vek280-sdt-seg-ospi = "${MACHINE}"
14
15# When do_upack is exectuted it will extract tar file with original directory
16# name so set the FW_DIR pointing to pdi and dtsi files.
17FW_DIR = "vek280-pl-bram-gpio-fw"
18
19# fw files doesn't install on rootfs using dfx_user_dts bbclass using artifactory
20# method. To workaround this issue we are using copy_fw_files pre-functions.
21# copy_fw_files prefuncs needs to be called before find_firmware_file to update
22# the firmware-name to ${PN}.
23do_configure[prefuncs] =+ "copy_fw_files"
24python copy_fw_files () {
25 import shutil
26 fw_file_src = d.getVar('WORKDIR') + '/' + d.getVar("FW_DIR")
27 fw_file_dest = d.getVar('S')
28 shutil.copytree(fw_file_src, fw_file_dest, dirs_exist_ok=True)
29}