summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/conf/layer.conf4
-rw-r--r--meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc1
-rw-r--r--meta-xilinx-core/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc5
3 files changed, 5 insertions, 5 deletions
diff --git a/meta-xilinx-core/conf/layer.conf b/meta-xilinx-core/conf/layer.conf
index 112f287a..33dd732c 100644
--- a/meta-xilinx-core/conf/layer.conf
+++ b/meta-xilinx-core/conf/layer.conf
@@ -25,7 +25,7 @@ xilinx-tools:${LAYERDIR}/dynamic-layers/meta-xilinx-tools/recipes-*/*/*.bbappend
25LAYERDEPENDS_xilinx = "core" 25LAYERDEPENDS_xilinx = "core"
26LAYERRECOMMENDS_xilinx = "openembedded-layer chromium-browser-layer" 26LAYERRECOMMENDS_xilinx = "openembedded-layer chromium-browser-layer"
27 27
28LAYERSERIES_COMPAT_xilinx = "kirkstone" 28LAYERSERIES_COMPAT_xilinx = "langdale"
29 29
30SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \ 30SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
31 *->zocl \ 31 *->zocl \
@@ -46,8 +46,6 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
46 46
47XILINX_RELEASE_VERSION ??= "v2022.2" 47XILINX_RELEASE_VERSION ??= "v2022.2"
48 48
49XILINX_DEPRECATED[meta-xilinx] = "Kirkstone is not officially supported. See the meta-xilinx/README.kirkstone file for more information."
50
51BUILDCFG_VARS:append = " XILINX_RELEASE_VERSION" 49BUILDCFG_VARS:append = " XILINX_RELEASE_VERSION"
52 50
53PREFERRED_VERSION_qemu-xilinx ?= "v6.1.0-xilinx-${XILINX_RELEASE_VERSION}%" 51PREFERRED_VERSION_qemu-xilinx ?= "v6.1.0-xilinx-${XILINX_RELEASE_VERSION}%"
diff --git a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
index aa91f771..7d3d45f3 100644
--- a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
+++ b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
@@ -33,7 +33,6 @@ XSERVER ?= " \
33 xserver-xorg \ 33 xserver-xorg \
34 xf86-input-evdev \ 34 xf86-input-evdev \
35 xf86-input-mouse \ 35 xf86-input-mouse \
36 xf86-input-keyboard \
37 xf86-video-fbdev \ 36 xf86-video-fbdev \
38 ${XSERVER_EXT} \ 37 ${XSERVER_EXT} \
39 " 38 "
diff --git a/meta-xilinx-core/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc b/meta-xilinx-core/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
index 5efd99ea..a8f512a7 100644
--- a/meta-xilinx-core/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
+++ b/meta-xilinx-core/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
@@ -75,12 +75,15 @@ EXTRA_OEMAKE:append:versal-net = "${@' VERSAL_NET_ATF_MEM_SIZE=${ATF_MEM_SIZE}'
75ATF_PROVENCORE = "SPD=pncd SPD_PNCD_NS_IRQ=51 ZYNQMP_BL32_MEM_BASE=0x70000000 ZYNQMP_BL32_MEM_SIZE=0x0FF00000" 75ATF_PROVENCORE = "SPD=pncd SPD_PNCD_NS_IRQ=51 ZYNQMP_BL32_MEM_BASE=0x70000000 ZYNQMP_BL32_MEM_SIZE=0x0FF00000"
76EXTRA_OEMAKE:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' ${ATF_PROVENCORE}', '', d)}" 76EXTRA_OEMAKE:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' ${ATF_PROVENCORE}', '', d)}"
77 77
78# Workaround for bl31.elf has a LOAD segment with RWX permissions
79EXTRA_OEMAKE:append = ' TF_LDFLAGS="--no-warn-rwx-segments --fatal-warnings -O1 --gc-sections"'
80
78do_configure() { 81do_configure() {
79 oe_runmake clean -C ${S} BUILD_BASE=${B} PLAT=${PLATFORM} 82 oe_runmake clean -C ${S} BUILD_BASE=${B} PLAT=${PLATFORM}
80} 83}
81 84
82do_compile() { 85do_compile() {
83 oe_runmake -C ${S} BUILD_BASE=${B} PLAT=${PLATFORM} RESET_TO_BL31=1 bl31 86 oe_runmake -C ${S} BUILD_BASE=${B} PLAT=${PLATFORM} RESET_TO_BL31=1 bl31 V=1
84} 87}
85 88
86do_install() { 89do_install() {