summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb')
-rw-r--r--meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb b/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb
new file mode 100644
index 00000000..7063178a
--- /dev/null
+++ b/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Xilinx Runtime(XRT) driver module"
2DESCRIPTION = "Xilinx Runtime driver module provides memory management and compute unit schedule"
3
4
5require recipes-xrt/xrt/xrt-${PV}.inc
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8"
8LICENSE = "GPLv2 & Apache-2.0"
9
10# Temporary fix
11# Patch is applied as -p 4 to the src/runtime_src/core/edge directory
12SRC_URI += "file://0001-Fixed-ZOCL-dtbo-path-len-issue-6966.patch;striplevel=5;patchdir=./../../"
13
14S = "${WORKDIR}/git/src/runtime_src/core/edge/drm/zocl"
15
16inherit module
17
18pkg_postinst_ontarget:${PN}() {
19 #!/bin/sh
20 echo "Unloading old XRT Linux kernel modules"
21 ( rmmod zocl || true ) > /dev/null 2>&1
22 echo "Loading new XRT Linux kernel modules"
23 modprobe zocl
24}