summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend')
-rw-r--r--meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend b/meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend
new file mode 100644
index 00000000..aa552fe5
--- /dev/null
+++ b/meta-xilinx-core/recipes-kernel/lopper/lopper.bbappend
@@ -0,0 +1,54 @@
1DEPENDS = " \
2 dtc \
3 python3-dtc \
4 python3-flask \
5 python3-flask-restful \
6 python3-six \
7 python3-pandas \
8 python3-ruamel-yaml \
9 python3-anytree \
10 python3-pyyaml \
11 python3-humanfriendly \
12"
13
14RDEPENDS:${PN} += " \
15 python3-flask \
16 python3-flask-restful \
17 python3-six \
18 python3-pandas \
19 python3-ruamel-yaml \
20 python3-anytree \
21 python3-pyyaml \
22"
23
24SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master"
25SRCREV = "4fc085c4be031996e7f48dcaf03d0782989c8d58"
26
27do_install() {
28 install -d "${D}/${bindir}"
29 install -d "${D}/${datadir}/${BPN}"
30
31 install -m 0644 "${S}/README" "${D}/${datadir}/${BPN}"
32 install -m 0644 "${S}/README-architecture.txt" "${D}/${datadir}/${BPN}"
33 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}"
34 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}"
35
36 install -d "${D}/${datadir}/${BPN}/assists"
37 #install -m 0644 "${S}/assists/"* "${D}/${datadir}/${BPN}/assists/"
38 cp -r "${S}/assists/"* "${D}/${datadir}/${BPN}/assists/"
39
40 install -d "${D}/${datadir}/${BPN}/lops"
41 install -m 0644 "${S}/lops/"* "${D}/${datadir}/${BPN}/lops/"
42
43 install -d "${D}/${datadir}/${BPN}/device-trees"
44 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/"
45
46 install -m 0644 "${S}/"lopper.ini "${D}/${datadir}/${BPN}/"
47
48 install -m 0755 "${S}/"lopper*.py "${D}/${datadir}/${BPN}/"
49 sed -i 's,#!/usr/bin/python3,#!/usr/bin/env python3,' ${D}/${datadir}/${BPN}/lopper.py
50 sed -i 's,#!/usr/bin/python3,#!/usr/bin/env python3,' ${D}/${datadir}/${BPN}/lopper_sanity.py
51
52 datadir_relpath=${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}
53 ln -s "${datadir_relpath}/${BPN}/lopper.py" "${D}/${bindir}/"
54}