summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb')
-rwxr-xr-xmeta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb b/meta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb
new file mode 100755
index 00000000..4d8bd265
--- /dev/null
+++ b/meta-xilinx-core/recipes-kernel/dp/kernel-module-dp_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Xilinx DisplayPort Linux Kernel module"
2DESCRIPTION = "Out-of-tree DisplayPort(DP) kernel modules provider for aarch64 devices"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eb723b61539feef013de476e68b5c50a"
6
7XLNX_DP_VERSION = "5.10.0"
8PV = "${XLNX_DP_VERSION}"
9
10S = "${WORKDIR}/git"
11
12BRANCH ?= "xlnx_rel_v2021.2"
13REPO ?= "git://github.com/xilinx/dp-modules.git;protocol=https"
14SRCREV ?= "46d4790c3d37ad4b878c5a1704df26edb56314f5"
15
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}"
18
19inherit module
20
21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
22COMPATIBLE_MACHINE = "^$"
23COMPATIBLE_MACHINE:zynqmp = "zynqmp"
24COMPATIBLE_MACHINE:versal = "versal"