summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-bsp/u-boot')
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
index b26f23ff..a4d7175b 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb
@@ -71,7 +71,14 @@ DEVICETREE_OFFSET:zynqmp ?= "0x100000"
71DEVICETREE_OFFSET:zynq ?= "0x100000" 71DEVICETREE_OFFSET:zynq ?= "0x100000"
72DEVICETREE_OFFSET:versal ?= "0x1000" 72DEVICETREE_OFFSET:versal ?= "0x1000"
73 73
74DEVICETREE_OVERLAY_ADDRESS ?= "${@hex(int(d.getVar("DEVICETREE_ADDRESS"),16) + 0xf00000)}" 74DEVICETREE_OVERLAY_OFFSET:microblaze ?= "0x1e00000"
75DEVICETREE_OVERLAY_OFFSET:zynqmp ?= "0x100000"
76DEVICETREE_OVERLAY_OFFSET:zynq ?= "0x100000"
77DEVICETREE_OVERLAY_OFFSET:versal ?= "0x1000"
78DEVICETREE_OVERLAY_PADSIZE ?= "0xf00000"
79
80DEVICETREE_OVERLAY_ADDRESS ?= "${@hex(int(append_baseaddr(d,d.getVar('DEVICETREE_OVERLAY_OFFSET')),16) \
81 + int(d.getVar('DEVICETREE_OVERLAY_PADSIZE'),16))}"
75 82
76KERNEL_LOAD_ADDRESS ?= "${@append_baseaddr(d,d.getVar('KERNEL_OFFSET'))}" 83KERNEL_LOAD_ADDRESS ?= "${@append_baseaddr(d,d.getVar('KERNEL_OFFSET'))}"
77 84
@@ -183,6 +190,9 @@ def append_baseaddr(d,offset):
183 skip_append = d.getVar('SKIP_APPEND_BASEADDR') or "" 190 skip_append = d.getVar('SKIP_APPEND_BASEADDR') or ""
184 if skip_append == "1": 191 if skip_append == "1":
185 return offset 192 return offset
193 if offset.startswith('$'):
194 # If offset startswith '$' Assuming as uboot env variable.
195 return offset
186 import subprocess 196 import subprocess
187 baseaddr = d.getVar('DDR_BASEADDR') or "0x0" 197 baseaddr = d.getVar('DDR_BASEADDR') or "0x0"
188 subcmd = "$((%s+%s));" % (baseaddr,offset) 198 subcmd = "$((%s+%s));" % (baseaddr,offset)