summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb')
-rw-r--r--meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb b/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb
new file mode 100644
index 00000000..8a707df4
--- /dev/null
+++ b/meta-xilinx-core/recipes-apps/image-update/image-update_1.1.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Image update is used to update alternate images on compatible firmware."
2SUMMARY = "Image update is used to update alternate image on compatible firmware. \
3 If the current image is ImageA, ImageB will get updated and vice versa. \
4 Usage: image_update <Input Image File>"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSES/MIT;md5=2ac09a7a37dd6ee0ba23ce497d57d09b"
8
9BRANCH = "xlnx_rel_v2023.2"
10SRC_URI = "git://github.com/Xilinx/linux-image_update.git;branch=${BRANCH};protocol=https"
11SRCREV = "4f0b7b1b20933ddc454124fc3472f1b8894ddf08"
12
13RDEPENDS:${PN} += "freeipmi"
14
15S = "${WORKDIR}/git"
16
17COMPATIBLE_MACHINE = "^$"
18COMPATIBLE_MACHINE:zynqmp = "zynqmp"
19
20PACKAGE_ARCH:zynqmp = "${SOC_FAMILY_ARCH}"
21
22# Force the make system to use the flags we want!
23EXTRA_OEMAKE = 'CC="${CC} ${TARGET_CFLAGS} ${TARGET_LDFLAGS}" all'
24
25do_install () {
26 install -d ${D}${bindir}
27 install -m 0755 ${S}/image_update ${D}${bindir}/
28}