summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-bsp')
-rw-r--r--meta-xilinx-bsp/conf/machine/sp701-microblazeel.conf52
-rw-r--r--meta-xilinx-bsp/conf/machine/zcu104-zynqmp.conf2
-rw-r--r--meta-xilinx-bsp/conf/machine/zcu106-zynqmp.conf2
-rw-r--r--meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend2
-rw-r--r--meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi20
-rw-r--r--meta-xilinx-bsp/recipes-bsp/dfx-mgr/dfx-mgr_%.bbappend2
6 files changed, 77 insertions, 3 deletions
diff --git a/meta-xilinx-bsp/conf/machine/sp701-microblazeel.conf b/meta-xilinx-bsp/conf/machine/sp701-microblazeel.conf
new file mode 100644
index 00000000..e3df1d26
--- /dev/null
+++ b/meta-xilinx-bsp/conf/machine/sp701-microblazeel.conf
@@ -0,0 +1,52 @@
1#@TYPE: Machine
2#@NAME: sp701-microblazeel
3#@DESCRIPTION: Machine configuration for the SP701 boards.
4
5#### Preamble
6MACHINEOVERRIDES =. "${@['', 'sp701-microblazeel:']['sp701-microblazeel' !='${MACHINE}']}"
7#### Regular settings follow
8
9# Variables that changes based on hw design or board specific requirement must be
10# defined before calling the required inclusion file else pre-expansion value
11# defined in microblazeel-generic.conf will be set.
12
13# Yocto device-tree variables
14YAML_CONSOLE_DEVICE_CONFIG:pn-device-tree ?= "axi_uartlite_0"
15YAML_MAIN_MEMORY_CONFIG:pn-device-tree ?= "MIG_7SERIES_0"
16DT_PADDING_SIZE:pn-device-tree ?= "0x1000"
17DTC_FLAGS:pn-device-tree ?= ""
18XSCTH_PROC:pn-device-tree ?= "microblaze_0"
19YAML_DT_BOARD_FLAGS ?= "{BOARD sp701-rev1.0}"
20
21# Yocto u-boot-xlnx variables
22
23# Yocto FS-Boot variables
24YAML_SERIAL_CONSOLE_STDIN:pn-fs-boot ?= "axi_uartlite_0"
25YAML_SERIAL_CONSOLE_STDOUT:pn-fs-boot ?= "axi_uartlite_0"
26YAML_MAIN_MEMORY_CONFIG:pn-fs-boot ?= "MIG_7SERIES_0"
27YAML_FLASH_MEMORY_CONFIG:pn-fs-boot ?= "axi_quad_spi_0"
28XSCTH_PROC:pn-fs-boot ?= "microblaze_0"
29
30# Yocto KERNEL Variables
31UBOOT_ENTRYPOINT ?= "0x80000000"
32UBOOT_LOADADDRESS ?= "0x80000000"
33
34# xilinx-sp701 Serial Console
35SERIAL_CONSOLES ?= "115200;ttyUL0"
36YAML_SERIAL_CONSOLE_BAUDRATE ?= "115200"
37
38# Set DDR Base address for u-boot-xlnx-scr variables
39DDR_BASEADDR ?= "0x80000000"
40SKIP_APPEND_BASEADDR ?= "0"
41
42# Required generic machine inclusion
43require conf/machine/microblaze-generic.conf
44
45# This machine conf file uses sp701-microblazeel xsa as reference input.
46# User can override with kc705 custom xsa using HDF_BASE and HDF_PATH variables
47# from local.conf.
48HDF_MACHINE = "sp701-microblazeel"
49
50#### No additional settings should be after the Postamble
51#### Postamble
52PACKAGE_EXTRA_ARCHS:append = "${@['', ' sp701_microblazeel']['sp701-microblazeel' != '${MACHINE}']}"
diff --git a/meta-xilinx-bsp/conf/machine/zcu104-zynqmp.conf b/meta-xilinx-bsp/conf/machine/zcu104-zynqmp.conf
index b4c11f3a..bff853b8 100644
--- a/meta-xilinx-bsp/conf/machine/zcu104-zynqmp.conf
+++ b/meta-xilinx-bsp/conf/machine/zcu104-zynqmp.conf
@@ -50,7 +50,7 @@ HDF_MACHINE = "zcu104-zynqmp"
50# KERNEL_DEVICETREE = "xilinx/zynqmp-zcu104-revC.dtb" 50# KERNEL_DEVICETREE = "xilinx/zynqmp-zcu104-revC.dtb"
51 51
52# Yocto IMAGE_FEATURES Variable 52# Yocto IMAGE_FEATURES Variable
53MACHINE_HWCODECS = "libomxil-xlnx" 53MACHINE_HWCODECS = "libvcu-omxil"
54IMAGE_FEATURES += "hwcodecs" 54IMAGE_FEATURES += "hwcodecs"
55 55
56#### No additional settings should be after the Postamble 56#### No additional settings should be after the Postamble
diff --git a/meta-xilinx-bsp/conf/machine/zcu106-zynqmp.conf b/meta-xilinx-bsp/conf/machine/zcu106-zynqmp.conf
index ff273134..cc2c6083 100644
--- a/meta-xilinx-bsp/conf/machine/zcu106-zynqmp.conf
+++ b/meta-xilinx-bsp/conf/machine/zcu106-zynqmp.conf
@@ -50,7 +50,7 @@ HDF_MACHINE = "zcu106-zynqmp"
50# KERNEL_DEVICETREE = "xilinx/zynqmp-zcu106-revA.dtb" 50# KERNEL_DEVICETREE = "xilinx/zynqmp-zcu106-revA.dtb"
51 51
52# Yocto IMAGE_FEATURES Variable 52# Yocto IMAGE_FEATURES Variable
53MACHINE_HWCODECS = "libomxil-xlnx" 53MACHINE_HWCODECS = "libvcu-omxil"
54IMAGE_FEATURES += "hwcodecs" 54IMAGE_FEATURES += "hwcodecs"
55 55
56#### No additional settings should be after the Postamble 56#### No additional settings should be after the Postamble
diff --git a/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend b/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
index fa4816af..7acda75e 100644
--- a/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
+++ b/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
@@ -5,3 +5,5 @@ COMPATIBLE_MACHINE:qemu-zynq7 = ".*"
5SRC_URI:append:qemu-zynq7 = " file://qemu-zynq7.dts" 5SRC_URI:append:qemu-zynq7 = " file://qemu-zynq7.dts"
6 6
7EXTRA_OVERLAYS:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' pnc.dtsi', '', d)}" 7EXTRA_OVERLAYS:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' pnc.dtsi', '', d)}"
8
9EXTRA_OVERLAYS:append:vek280-versal = " system-vek280.dtsi"
diff --git a/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi b/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi
new file mode 100644
index 00000000..0d2ca87d
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi
@@ -0,0 +1,20 @@
1/ {
2/* Reserve the bad block DDR memory for linux to not touch it, refer:CR-1143646 */
3reserved-memory {
4 #address-cells = <2>;
5 #size-cells = <2>;
6 ranges;
7 pl_ddr: buffer@0
8 {
9 no-map;
10 reg = <0x08 0x00 0x00 0x80000000>;
11 };
12
13 lpddr_memory: buffer@1
14 {
15 no-map;
16 reg = <0x500 0x0 0x2 0x0>;
17 };
18
19};
20};
diff --git a/meta-xilinx-bsp/recipes-bsp/dfx-mgr/dfx-mgr_%.bbappend b/meta-xilinx-bsp/recipes-bsp/dfx-mgr/dfx-mgr_%.bbappend
index 8fdf14bb..1ff1e058 100644
--- a/meta-xilinx-bsp/recipes-bsp/dfx-mgr/dfx-mgr_%.bbappend
+++ b/meta-xilinx-bsp/recipes-bsp/dfx-mgr/dfx-mgr_%.bbappend
@@ -6,5 +6,5 @@ PACKAGE_ARCH:zcu106-zynqmp = "${MACHINE_ARCH}"
6 6
7# ZCU106 eval board firmware detection script. 7# ZCU106 eval board firmware detection script.
8do_install:append:zcu106-zynqmp () { 8do_install:append:zcu106-zynqmp () {
9 install -m 0755 ${WORKDIR}/zcu106-xlnx-firmware-detect ${D}${bindir}/xlnx-firmware-detect 9 install -m 0755 ${UNPACKDIR}/zcu106-xlnx-firmware-detect ${D}${bindir}/xlnx-firmware-detect
10} 10}