summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch')
-rw-r--r--meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch107
1 files changed, 53 insertions, 54 deletions
diff --git a/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
index 9a1a8bd2..3bf75d32 100644
--- a/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
+++ b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
@@ -2,32 +2,32 @@ Add microblaze syscalls to systemd
2 2
3Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> 3Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
4 4
5diff --git a/src/basic/meson.build b/src/basic/meson.build 5Index: git/src/basic/meson.build
6index 9b016ce5e8..a896e3c464 100644 6===================================================================
7--- a/src/basic/meson.build 7--- git.orig/src/basic/meson.build
8+++ b/src/basic/meson.build 8+++ git/src/basic/meson.build
9@@ -332,6 +332,7 @@ arch_list = [ 9@@ -347,6 +347,7 @@ arch_list = [
10 'i386',
11 'ia64', 10 'ia64',
11 'loongarch64',
12 'm68k', 12 'm68k',
13+ 'microblaze', 13+ 'microblaze',
14 'mips64', 14 'mips64',
15 'mips64n32', 15 'mips64n32',
16 'mipso32', 16 'mipso32',
17diff --git a/src/basic/missing_syscall_def.h b/src/basic/missing_syscall_def.h 17Index: git/src/basic/missing_syscall_def.h
18index 6a48c2a0c5..ed7df7c07d 100644 18===================================================================
19--- a/src/basic/missing_syscall_def.h 19--- git.orig/src/basic/missing_syscall_def.h
20+++ b/src/basic/missing_syscall_def.h 20+++ git/src/basic/missing_syscall_def.h
21@@ -14,6 +14,7 @@ 21@@ -16,6 +16,7 @@
22 # elif defined(__i386__)
23 # elif defined(__ia64__) 22 # elif defined(__ia64__)
23 # elif defined(__loongarch64)
24 # elif defined(__m68k__) 24 # elif defined(__m68k__)
25+# elif defined(__microblaze__) 25+# elif defined(__microblaze__)
26 # elif defined(_MIPS_SIM) 26 # elif defined(_MIPS_SIM)
27 # if _MIPS_SIM == _MIPS_SIM_ABI32 27 # if _MIPS_SIM == _MIPS_SIM_ABI32
28 # elif _MIPS_SIM == _MIPS_SIM_NABI32 28 # elif _MIPS_SIM == _MIPS_SIM_NABI32
29@@ -54,6 +55,8 @@ 29@@ -58,6 +59,8 @@
30 # define systemd_NR_bpf 1341 30 # define systemd_NR_bpf 280
31 # elif defined(__m68k__) 31 # elif defined(__m68k__)
32 # define systemd_NR_bpf 354 32 # define systemd_NR_bpf 354
33+# elif defined(__microblaze__) 33+# elif defined(__microblaze__)
@@ -35,8 +35,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
35 # elif defined(_MIPS_SIM) 35 # elif defined(_MIPS_SIM)
36 # if _MIPS_SIM == _MIPS_SIM_ABI32 36 # if _MIPS_SIM == _MIPS_SIM_ABI32
37 # define systemd_NR_bpf 4355 37 # define systemd_NR_bpf 4355
38@@ -118,6 +121,8 @@ assert_cc(__NR_bpf == systemd_NR_bpf); 38@@ -124,6 +127,8 @@ assert_cc(__NR_bpf == systemd_NR_bpf);
39 # define systemd_NR_close_range 1460 39 # define systemd_NR_close_range 436
40 # elif defined(__m68k__) 40 # elif defined(__m68k__)
41 # define systemd_NR_close_range 436 41 # define systemd_NR_close_range 436
42+# elif defined(__microblaze__) 42+# elif defined(__microblaze__)
@@ -44,8 +44,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
44 # elif defined(_MIPS_SIM) 44 # elif defined(_MIPS_SIM)
45 # if _MIPS_SIM == _MIPS_SIM_ABI32 45 # if _MIPS_SIM == _MIPS_SIM_ABI32
46 # define systemd_NR_close_range 4436 46 # define systemd_NR_close_range 4436
47@@ -182,6 +187,8 @@ assert_cc(__NR_close_range == systemd_NR_close_range); 47@@ -190,6 +195,8 @@ assert_cc(__NR_close_range == systemd_NR
48 # define systemd_NR_copy_file_range 1347 48 # define systemd_NR_copy_file_range 285
49 # elif defined(__m68k__) 49 # elif defined(__m68k__)
50 # define systemd_NR_copy_file_range 376 50 # define systemd_NR_copy_file_range 376
51+# elif defined(__microblaze__) 51+# elif defined(__microblaze__)
@@ -53,8 +53,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
53 # elif defined(_MIPS_SIM) 53 # elif defined(_MIPS_SIM)
54 # if _MIPS_SIM == _MIPS_SIM_ABI32 54 # if _MIPS_SIM == _MIPS_SIM_ABI32
55 # define systemd_NR_copy_file_range 4360 55 # define systemd_NR_copy_file_range 4360
56@@ -246,6 +253,8 @@ assert_cc(__NR_copy_file_range == systemd_NR_copy_file_range); 56@@ -256,6 +263,8 @@ assert_cc(__NR_copy_file_range == system
57 # define systemd_NR_epoll_pwait2 1465 57 # define systemd_NR_epoll_pwait2 441
58 # elif defined(__m68k__) 58 # elif defined(__m68k__)
59 # define systemd_NR_epoll_pwait2 441 59 # define systemd_NR_epoll_pwait2 441
60+# elif defined(__microblaze__) 60+# elif defined(__microblaze__)
@@ -62,8 +62,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
62 # elif defined(_MIPS_SIM) 62 # elif defined(_MIPS_SIM)
63 # if _MIPS_SIM == _MIPS_SIM_ABI32 63 # if _MIPS_SIM == _MIPS_SIM_ABI32
64 # define systemd_NR_epoll_pwait2 4441 64 # define systemd_NR_epoll_pwait2 4441
65@@ -310,6 +319,8 @@ assert_cc(__NR_epoll_pwait2 == systemd_NR_epoll_pwait2); 65@@ -322,6 +331,8 @@ assert_cc(__NR_epoll_pwait2 == systemd_N
66 # define systemd_NR_getrandom 1339 66 # define systemd_NR_getrandom 278
67 # elif defined(__m68k__) 67 # elif defined(__m68k__)
68 # define systemd_NR_getrandom 352 68 # define systemd_NR_getrandom 352
69+# elif defined(__microblaze__) 69+# elif defined(__microblaze__)
@@ -71,8 +71,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
71 # elif defined(_MIPS_SIM) 71 # elif defined(_MIPS_SIM)
72 # if _MIPS_SIM == _MIPS_SIM_ABI32 72 # if _MIPS_SIM == _MIPS_SIM_ABI32
73 # define systemd_NR_getrandom 4353 73 # define systemd_NR_getrandom 4353
74@@ -374,6 +385,8 @@ assert_cc(__NR_getrandom == systemd_NR_getrandom); 74@@ -388,6 +399,8 @@ assert_cc(__NR_getrandom == systemd_NR_g
75 # define systemd_NR_memfd_create 1340 75 # define systemd_NR_memfd_create 279
76 # elif defined(__m68k__) 76 # elif defined(__m68k__)
77 # define systemd_NR_memfd_create 353 77 # define systemd_NR_memfd_create 353
78+# elif defined(__microblaze__) 78+# elif defined(__microblaze__)
@@ -80,8 +80,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
80 # elif defined(_MIPS_SIM) 80 # elif defined(_MIPS_SIM)
81 # if _MIPS_SIM == _MIPS_SIM_ABI32 81 # if _MIPS_SIM == _MIPS_SIM_ABI32
82 # define systemd_NR_memfd_create 4354 82 # define systemd_NR_memfd_create 4354
83@@ -438,6 +451,8 @@ assert_cc(__NR_memfd_create == systemd_NR_memfd_create); 83@@ -454,6 +467,8 @@ assert_cc(__NR_memfd_create == systemd_N
84 # define systemd_NR_mount_setattr 1466 84 # define systemd_NR_mount_setattr 442
85 # elif defined(__m68k__) 85 # elif defined(__m68k__)
86 # define systemd_NR_mount_setattr 442 86 # define systemd_NR_mount_setattr 442
87+# elif defined(__microblaze__) 87+# elif defined(__microblaze__)
@@ -89,8 +89,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
89 # elif defined(_MIPS_SIM) 89 # elif defined(_MIPS_SIM)
90 # if _MIPS_SIM == _MIPS_SIM_ABI32 90 # if _MIPS_SIM == _MIPS_SIM_ABI32
91 # define systemd_NR_mount_setattr 4442 91 # define systemd_NR_mount_setattr 4442
92@@ -502,6 +517,8 @@ assert_cc(__NR_mount_setattr == systemd_NR_mount_setattr); 92@@ -520,6 +535,8 @@ assert_cc(__NR_mount_setattr == systemd_
93 # define systemd_NR_move_mount 1453 93 # define systemd_NR_move_mount 429
94 # elif defined(__m68k__) 94 # elif defined(__m68k__)
95 # define systemd_NR_move_mount 429 95 # define systemd_NR_move_mount 429
96+# elif defined(__microblaze__) 96+# elif defined(__microblaze__)
@@ -98,8 +98,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
98 # elif defined(_MIPS_SIM) 98 # elif defined(_MIPS_SIM)
99 # if _MIPS_SIM == _MIPS_SIM_ABI32 99 # if _MIPS_SIM == _MIPS_SIM_ABI32
100 # define systemd_NR_move_mount 4429 100 # define systemd_NR_move_mount 4429
101@@ -566,6 +583,8 @@ assert_cc(__NR_move_mount == systemd_NR_move_mount); 101@@ -586,6 +603,8 @@ assert_cc(__NR_move_mount == systemd_NR_
102 # define systemd_NR_name_to_handle_at 1326 102 # define systemd_NR_name_to_handle_at 264
103 # elif defined(__m68k__) 103 # elif defined(__m68k__)
104 # define systemd_NR_name_to_handle_at 340 104 # define systemd_NR_name_to_handle_at 340
105+# elif defined(__microblaze__) 105+# elif defined(__microblaze__)
@@ -107,8 +107,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
107 # elif defined(_MIPS_SIM) 107 # elif defined(_MIPS_SIM)
108 # if _MIPS_SIM == _MIPS_SIM_ABI32 108 # if _MIPS_SIM == _MIPS_SIM_ABI32
109 # define systemd_NR_name_to_handle_at 4339 109 # define systemd_NR_name_to_handle_at 4339
110@@ -630,6 +649,8 @@ assert_cc(__NR_name_to_handle_at == systemd_NR_name_to_handle_at); 110@@ -652,6 +671,8 @@ assert_cc(__NR_name_to_handle_at == syst
111 # define systemd_NR_open_tree 1452 111 # define systemd_NR_open_tree 428
112 # elif defined(__m68k__) 112 # elif defined(__m68k__)
113 # define systemd_NR_open_tree 428 113 # define systemd_NR_open_tree 428
114+# elif defined(__microblaze__) 114+# elif defined(__microblaze__)
@@ -116,8 +116,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
116 # elif defined(_MIPS_SIM) 116 # elif defined(_MIPS_SIM)
117 # if _MIPS_SIM == _MIPS_SIM_ABI32 117 # if _MIPS_SIM == _MIPS_SIM_ABI32
118 # define systemd_NR_open_tree 4428 118 # define systemd_NR_open_tree 4428
119@@ -694,6 +715,8 @@ assert_cc(__NR_open_tree == systemd_NR_open_tree); 119@@ -784,6 +805,8 @@ assert_cc(__NR_openat2 == systemd_NR_ope
120 # define systemd_NR_pidfd_open 1458 120 # define systemd_NR_pidfd_open 434
121 # elif defined(__m68k__) 121 # elif defined(__m68k__)
122 # define systemd_NR_pidfd_open 434 122 # define systemd_NR_pidfd_open 434
123+# elif defined(__microblaze__) 123+# elif defined(__microblaze__)
@@ -125,8 +125,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
125 # elif defined(_MIPS_SIM) 125 # elif defined(_MIPS_SIM)
126 # if _MIPS_SIM == _MIPS_SIM_ABI32 126 # if _MIPS_SIM == _MIPS_SIM_ABI32
127 # define systemd_NR_pidfd_open 4434 127 # define systemd_NR_pidfd_open 4434
128@@ -758,6 +781,8 @@ assert_cc(__NR_pidfd_open == systemd_NR_pidfd_open); 128@@ -850,6 +873,8 @@ assert_cc(__NR_pidfd_open == systemd_NR_
129 # define systemd_NR_pidfd_send_signal 1448 129 # define systemd_NR_pidfd_send_signal 424
130 # elif defined(__m68k__) 130 # elif defined(__m68k__)
131 # define systemd_NR_pidfd_send_signal 424 131 # define systemd_NR_pidfd_send_signal 424
132+# elif defined(__microblaze__) 132+# elif defined(__microblaze__)
@@ -134,8 +134,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
134 # elif defined(_MIPS_SIM) 134 # elif defined(_MIPS_SIM)
135 # if _MIPS_SIM == _MIPS_SIM_ABI32 135 # if _MIPS_SIM == _MIPS_SIM_ABI32
136 # define systemd_NR_pidfd_send_signal 4424 136 # define systemd_NR_pidfd_send_signal 4424
137@@ -822,6 +847,8 @@ assert_cc(__NR_pidfd_send_signal == systemd_NR_pidfd_send_signal); 137@@ -916,6 +941,8 @@ assert_cc(__NR_pidfd_send_signal == syst
138 # define systemd_NR_pkey_mprotect 1354 138 # define systemd_NR_pkey_mprotect 288
139 # elif defined(__m68k__) 139 # elif defined(__m68k__)
140 # define systemd_NR_pkey_mprotect 381 140 # define systemd_NR_pkey_mprotect 381
141+# elif defined(__microblaze__) 141+# elif defined(__microblaze__)
@@ -143,8 +143,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
143 # elif defined(_MIPS_SIM) 143 # elif defined(_MIPS_SIM)
144 # if _MIPS_SIM == _MIPS_SIM_ABI32 144 # if _MIPS_SIM == _MIPS_SIM_ABI32
145 # define systemd_NR_pkey_mprotect 4363 145 # define systemd_NR_pkey_mprotect 4363
146@@ -886,6 +913,8 @@ assert_cc(__NR_pkey_mprotect == systemd_NR_pkey_mprotect); 146@@ -982,6 +1009,8 @@ assert_cc(__NR_pkey_mprotect == systemd_
147 # define systemd_NR_renameat2 1338 147 # define systemd_NR_renameat2 276
148 # elif defined(__m68k__) 148 # elif defined(__m68k__)
149 # define systemd_NR_renameat2 351 149 # define systemd_NR_renameat2 351
150+# elif defined(__microblaze__) 150+# elif defined(__microblaze__)
@@ -152,8 +152,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
152 # elif defined(_MIPS_SIM) 152 # elif defined(_MIPS_SIM)
153 # if _MIPS_SIM == _MIPS_SIM_ABI32 153 # if _MIPS_SIM == _MIPS_SIM_ABI32
154 # define systemd_NR_renameat2 4351 154 # define systemd_NR_renameat2 4351
155@@ -950,6 +979,8 @@ assert_cc(__NR_renameat2 == systemd_NR_renameat2); 155@@ -1048,6 +1077,8 @@ assert_cc(__NR_renameat2 == systemd_NR_r
156 # define systemd_NR_setns 1330 156 # define systemd_NR_setns 268
157 # elif defined(__m68k__) 157 # elif defined(__m68k__)
158 # define systemd_NR_setns 344 158 # define systemd_NR_setns 344
159+# elif defined(__microblaze__) 159+# elif defined(__microblaze__)
@@ -161,8 +161,8 @@ index 6a48c2a0c5..ed7df7c07d 100644
161 # elif defined(_MIPS_SIM) 161 # elif defined(_MIPS_SIM)
162 # if _MIPS_SIM == _MIPS_SIM_ABI32 162 # if _MIPS_SIM == _MIPS_SIM_ABI32
163 # define systemd_NR_setns 4344 163 # define systemd_NR_setns 4344
164@@ -1014,6 +1045,8 @@ assert_cc(__NR_setns == systemd_NR_setns); 164@@ -1114,6 +1145,8 @@ assert_cc(__NR_setns == systemd_NR_setns
165 # define systemd_NR_statx 1350 165 # define systemd_NR_statx 291
166 # elif defined(__m68k__) 166 # elif defined(__m68k__)
167 # define systemd_NR_statx 379 167 # define systemd_NR_statx 379
168+# elif defined(__microblaze__) 168+# elif defined(__microblaze__)
@@ -170,12 +170,12 @@ index 6a48c2a0c5..ed7df7c07d 100644
170 # elif defined(_MIPS_SIM) 170 # elif defined(_MIPS_SIM)
171 # if _MIPS_SIM == _MIPS_SIM_ABI32 171 # if _MIPS_SIM == _MIPS_SIM_ABI32
172 # define systemd_NR_statx 4366 172 # define systemd_NR_statx 4366
173diff --git a/src/basic/missing_syscalls.py b/src/basic/missing_syscalls.py 173Index: git/src/basic/missing_syscalls.py
174index 19f9726d4e..66fd7615b4 100644 174===================================================================
175--- a/src/basic/missing_syscalls.py 175--- git.orig/src/basic/missing_syscalls.py
176+++ b/src/basic/missing_syscalls.py 176+++ git/src/basic/missing_syscalls.py
177@@ -61,6 +61,8 @@ DEF_TEMPLATE_B = '''\ 177@@ -64,6 +64,8 @@ DEF_TEMPLATE_B = '''\
178 # define systemd_NR_{syscall} {nr_ia64} 178 # define systemd_NR_{syscall} {nr_loongarch64}
179 # elif defined(__m68k__) 179 # elif defined(__m68k__)
180 # define systemd_NR_{syscall} {nr_m68k} 180 # define systemd_NR_{syscall} {nr_m68k}
181+# elif defined(__microblaze__) 181+# elif defined(__microblaze__)
@@ -183,11 +183,10 @@ index 19f9726d4e..66fd7615b4 100644
183 # elif defined(_MIPS_SIM) 183 # elif defined(_MIPS_SIM)
184 # if _MIPS_SIM == _MIPS_SIM_ABI32 184 # if _MIPS_SIM == _MIPS_SIM_ABI32
185 # define systemd_NR_{syscall} {nr_mipso32} 185 # define systemd_NR_{syscall} {nr_mipso32}
186diff --git a/src/basic/syscalls-microblaze.txt b/src/basic/syscalls-microblaze.txt 186Index: git/src/basic/syscalls-microblaze.txt
187new file mode 100644 187===================================================================
188index 0000000000..3fc4cd6aef
189--- /dev/null 188--- /dev/null
190+++ b/src/basic/syscalls-microblaze.txt 189+++ git/src/basic/syscalls-microblaze.txt
191@@ -0,0 +1,598 @@ 190@@ -0,0 +1,598 @@
192+_llseek 140 191+_llseek 140
193+_newselect 142 192+_newselect 142