summaryrefslogtreecommitdiffstats
path: root/docs/README.dfx.user.dts.md
diff options
context:
space:
mode:
Diffstat (limited to 'docs/README.dfx.user.dts.md')
-rw-r--r--docs/README.dfx.user.dts.md6
1 files changed, 3 insertions, 3 deletions
diff --git a/docs/README.dfx.user.dts.md b/docs/README.dfx.user.dts.md
index 6cfc5fd0..69e1e52b 100644
--- a/docs/README.dfx.user.dts.md
+++ b/docs/README.dfx.user.dts.md
@@ -128,12 +128,12 @@ SRC_URI = " \
1282. Create recipes-firmware directory in meta layer and copy the .bit/pdi, 1282. Create recipes-firmware directory in meta layer and copy the .bit/pdi,
129 .dtsi/dtbo, .json and .xclbin file to these directories. 129 .dtsi/dtbo, .json and .xclbin file to these directories.
130``` 130```
131$ mkdir -p <meta-layer>/recipes-fimrware/<recipes-firmware-app>/files 131$ mkdir -p <meta-layer>/recipes-firmware/<recipes-firmware-app>/files
132$ cp -r <path-to-files>/*.{bit or pdi, dtsi or dtbo, shell.json or accel.json and .xclbin} <meta-layer>/recipes-fimrware/<firmware-app-name>/files 132$ cp -r <path-to-files>/*.{bit or pdi, dtsi or dtbo, shell.json or accel.json and .xclbin} <meta-layer>/recipes-firmware/<firmware-app-name>/files
133``` 133```
1343. Now create the recipes for flat or static or partial firmware using recipetool. 1343. Now create the recipes for flat or static or partial firmware using recipetool.
135``` 135```
136$ recipetool create -o <meta-layer>/recipes-fimrware/<firmware-app-name>/firmware-app-name.bb file:///<meta-layer>/recipes-fimrware/<firmware-app-name>/files 136$ recipetool create -o <meta-layer>/recipes-firmware/<firmware-app-name>/firmware-app-name.bb file:///<meta-layer>/recipes-firmware/<firmware-app-name>/files
137``` 137```
1384. Modify the recipe and inherit dfx_user_dts bbclass as shown below. 1384. Modify the recipe and inherit dfx_user_dts bbclass as shown below.
139``` 139```