summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--[-rwxr-xr-x]recipes-gnome/libffi/libffi_3.0.12.bb (renamed from recipes-gnome/libffi/libffi_git.bb)15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-gnome/libffi/libffi_git.bb b/recipes-gnome/libffi/libffi_3.0.12.bb
index 719a93f3..2c14e583 100755..100644
--- a/recipes-gnome/libffi/libffi_git.bb
+++ b/recipes-gnome/libffi/libffi_3.0.12.bb
@@ -9,13 +9,12 @@ A layer must exist above `libffi' that handles type conversions for values passe
9LICENSE = "MIT" 9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=e54c573c49435ccbbd3f6dc9e49a065e" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=e54c573c49435ccbbd3f6dc9e49a065e"
11 11
12S = "${WORKDIR}/git"
13PR = "r0" 12PR = "r0"
14 13
15BRANCH = "microblaze-support-rebase" 14SRC_URI = "ftp://sourceware.org/pub/libffi/${BPN}-${PV}.tar.gz"
16SRC_URI = "git://developer.petalogix.com/petalogix/internal/git/private/dev/nrossi/libffi;protocol=ssh;branch=${BRANCH}"
17 15
18SRCREV="${AUTOREV}" 16SRC_URI[md5sum] = "da984c6756170d50f47925bb333cda71"
17SRC_URI[sha256sum] = "2ea0db90c2bbcc907c3aefc3f76e9dfc3b35c7a0fb75a4319f5248e0172c1e9e"
19 18
20EXTRA_OECONF += "--disable-builddir" 19EXTRA_OECONF += "--disable-builddir"
21 20
@@ -24,11 +23,3 @@ inherit autotools
24FILES_${PN}-dev += "${libdir}/libffi-${PV}" 23FILES_${PN}-dev += "${libdir}/libffi-${PV}"
25 24
26BBCLASSEXTEND = "native nativesdk" 25BBCLASSEXTEND = "native nativesdk"
27
28autotools_do_configure() {
29 if [ -e ${S}/configure ]; then
30 oe_runconf
31 else
32 bbnote "nothing to configure"
33 fi
34}