summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/reference-design/kc705-bitstream_2017.3.bb (renamed from recipes-bsp/reference-design/kc705-bitstream_2016.3.bb)8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/reference-design/kc705-bitstream_2016.3.bb b/recipes-bsp/reference-design/kc705-bitstream_2017.3.bb
index 195d60cc..164df79b 100644
--- a/recipes-bsp/reference-design/kc705-bitstream_2016.3.bb
+++ b/recipes-bsp/reference-design/kc705-bitstream_2017.3.bb
@@ -13,11 +13,11 @@ COMPATIBLE_MACHINE = "kc705-microblazeel"
13inherit deploy 13inherit deploy
14inherit xilinx-fetch-restricted 14inherit xilinx-fetch-restricted
15 15
16BSP_NAME = "Xilinx-KC705" 16BSP_NAME = "xilinx-kc705"
17BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp" 17BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp"
18SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}" 18SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}"
19SRC_URI[md5sum] = "6a2276088759f10b9504eae2f13fe8a2" 19SRC_URI[md5sum] = "e4c4de43dcbcb955a3c63e4c68542792"
20SRC_URI[sha256sum] = "dbb722cc051a2d8517238948ddec1c029511ff391a8f9fc0b0f1e58e52ade399" 20SRC_URI[sha256sum] = "3e2b0e426958dad01a0ee810822001700065e9ed988f5c1c12b984ad2b48bc5c"
21 21
22PROVIDES = "virtual/bitstream" 22PROVIDES = "virtual/bitstream"
23 23
@@ -31,7 +31,7 @@ DEPENDS += "tar-native gzip-native"
31 31
32do_compile() { 32do_compile() {
33 # Extract the bitstream into workdir 33 # Extract the bitstream into workdir
34 tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-AXI-full-${PV}/pre-built/linux/images/download.bit -C ${S} 34 tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-axi-full-${PV}/pre-built/linux/images/download.bit -C ${S}
35 # move the bit file to ${S}/ as it is in a subdir in the tar file 35 # move the bit file to ${S}/ as it is in a subdir in the tar file
36 for i in $(find -type f -name download.bit); do mv $i ${S}; done 36 for i in $(find -type f -name download.bit); do mv $i ${S}; done
37} 37}