summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-06 16:06:35 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-13 16:11:14 -0800
commita18947c20dba2c0c38db8bde1ad4684995df4bbd (patch)
tree917bf2abbe439a6f99ede8cfafb25812dca54a9a /recipes-devtools
parent6ddc5873b0ede30e6542f0ab151a6236acc37944 (diff)
downloadmeta-xilinx-a18947c20dba2c0c38db8bde1ad4684995df4bbd.tar.gz
meta-xilinx: Restructuring meta-xilinx to support multiple layers
As discussed previously on mailing list, we are proceeding with layer restructuring. For rocko release we will have the following layers meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-xilinx-contrib In the subsequent releases we will add other layers from Xilinx meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-petalinux ->meta-xilinx-tools ->meta-xilinx-contrib This will provide one clone to get all the required meta layers from Xilinx for a complete solution, and the users can blacklist any layer which they don't want to use using bblayer.conf. This will enables us to help our vendors/partners to add their reference designs, board definitions etc. Recipe changes : * Move reference design zybo-linux-bd.bb to meta-xilinx-contrib * Move kernel patches realted to zybo-linux-bd-zynq7 board to meta-xilinx-contrib * Update README Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/files/qemu-system-aarch64-multiarch32
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees.inc37
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees_2017.3.bb4
-rw-r--r--recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb28
-rw-r--r--recipes-devtools/qemu/qemu-xilinx-multiarch-helper-native_1.0.bb20
-rw-r--r--recipes-devtools/qemu/qemu-xilinx.inc47
-rw-r--r--recipes-devtools/qemu/qemu-xilinx_2017.3.bb5
7 files changed, 0 insertions, 173 deletions
diff --git a/recipes-devtools/qemu/files/qemu-system-aarch64-multiarch b/recipes-devtools/qemu/files/qemu-system-aarch64-multiarch
deleted file mode 100644
index 15124c1b..00000000
--- a/recipes-devtools/qemu/files/qemu-system-aarch64-multiarch
+++ /dev/null
@@ -1,32 +0,0 @@
1#!/bin/bash
2
3BINPATH=$(dirname $0)
4MACHINE_PATH=$(mktemp -d)
5
6APU_ARGS=
7PMU_ARGS=
8
9while [ ! -z "$1" ]; do
10 if [ "$1" = "-pmu-args" ]; then
11 PMU_ARGS+=" $2"
12 shift
13 else
14 APU_ARGS+=" $1"
15 fi
16 shift
17done
18
19PMU_ROM=$(last=; for i in $PMU_ARGS; do if [ "$last" = "-kernel" ]; then echo "$i"; break; fi; last=$i; done)
20if [ ! -e $PMU_ROM ]; then
21 echo "------"
22 echo "Error: Missing PMU ROM - $PMU_ROM"
23 echo " See 'meta-xilinx/README.qemu.md' for more information on accquiring the PMU ROM."
24 echo "------"
25 exit 255
26fi
27
28# start the PMU instance
29$BINPATH/qemu-system-microblazeel $PMU_ARGS -machine-path $MACHINE_PATH &
30# start the APU instance
31$BINPATH/qemu-system-aarch64 $APU_ARGS -machine-path $MACHINE_PATH
32
diff --git a/recipes-devtools/qemu/qemu-devicetrees.inc b/recipes-devtools/qemu/qemu-devicetrees.inc
deleted file mode 100644
index d4044ed7..00000000
--- a/recipes-devtools/qemu/qemu-devicetrees.inc
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "Xilinx's hardware device trees required for QEMU"
2HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
3LICENSE = "BSD"
4DEPENDS += "dtc-native"
5
6inherit deploy
7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9
10PV = "xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
11
12BRANCH ?= ""
13REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https"
14
15BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
16SRC_URI = "${REPO};${BRANCHARG}"
17
18S = "${WORKDIR}/git"
19
20# Don't need to do anything
21do_install() {
22 :
23}
24
25do_deploy() {
26 # single-arch dtbs
27 for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
28 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/$(basename $DTS_FILE .dtb).dtb
29 done
30
31 # multi-arch dtbs
32 for DTS_FILE in ${S}/LATEST/MULTI_ARCH/*.dtb; do
33 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/multiarch/$(basename $DTS_FILE .dtb).dtb
34 done
35}
36
37addtask deploy after do_install
diff --git a/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb b/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
deleted file mode 100644
index ec6093b7..00000000
--- a/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1require qemu-devicetrees.inc
2
3XILINX_RELEASE_VERSION = "v2017.3"
4SRCREV ?= "4b951c594078562e9dd828430075968dd91ac425"
diff --git a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
deleted file mode 100644
index 55b35b53..00000000
--- a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1
2python () {
3 if d.getVar("PREFERRED_PROVIDER_qemu-helper-native") != d.getVar("PN"):
4 raise bb.parse.SkipRecipe("Set qemu-helper-native provider to use this recipe")
5}
6
7def get_filespath_extra(d, subpath):
8 metaroot = next((p for p in d.getVar('BBPATH').split(':') if os.path.basename(p) == 'meta'), None)
9 if metaroot:
10 return os.path.join(metaroot, subpath) + ":"
11 return ""
12
13# TODO: improve this, since it is very hacky that this recipe need to build tunctl.
14# include the existing qemu-helper-native
15require recipes-devtools/qemu/qemu-helper-native_1.0.bb
16# get the path to tunctl.c
17FILESEXTRAPATHS_prepend := "${@get_filespath_extra(d, 'recipes-devtools/qemu/qemu-helper')}"
18
19# provide it, to replace the existing
20PROVIDES += "qemu-helper-native"
21
22# replace qemu with qemu-xilinx
23DEPENDS_remove = "qemu-native"
24DEPENDS_append = " \
25 qemu-xilinx-native \
26 qemu-xilinx-multiarch-helper-native \
27 "
28
diff --git a/recipes-devtools/qemu/qemu-xilinx-multiarch-helper-native_1.0.bb b/recipes-devtools/qemu/qemu-xilinx-multiarch-helper-native_1.0.bb
deleted file mode 100644
index a9b11c6c..00000000
--- a/recipes-devtools/qemu/qemu-xilinx-multiarch-helper-native_1.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Helper scripts for executing a multi-arch instance of Xilinx QEMU"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4RDEPENDS_${PN} = "qemu-xilinx-native"
5
6inherit native
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
9
10SRC_URI = "file://qemu-system-aarch64-multiarch"
11
12do_configure[noexec] = "1"
13do_compile[noexec] = "1"
14
15SYSROOT_DIRS += "${bindir}/qemu-xilinx"
16
17do_install() {
18 install -Dm 0755 ${WORKDIR}/qemu-system-aarch64-multiarch ${D}${bindir}/qemu-xilinx/qemu-system-aarch64-multiarch
19}
20
diff --git a/recipes-devtools/qemu/qemu-xilinx.inc b/recipes-devtools/qemu/qemu-xilinx.inc
deleted file mode 100644
index 9b59ecce..00000000
--- a/recipes-devtools/qemu/qemu-xilinx.inc
+++ /dev/null
@@ -1,47 +0,0 @@
1QEMU_TARGETS = "aarch64 arm microblaze microblazeel"
2
3require recipes-devtools/qemu/qemu.inc
4
5SUMMARY = "Xilinx's fork of a fast open source processor emulator"
6HOMEPAGE = "https://github.com/xilinx/qemu/"
7
8LIC_FILES_CHKSUM = " \
9 file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \
11 "
12
13PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
14BRANCH ?= ""
15REPO ?= "git://github.com/Xilinx/qemu.git;protocol=https"
16
17BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
18SRC_URI = "${REPO};${BRANCHARG}"
19
20S = "${WORKDIR}/git"
21
22# Disable KVM completely
23PACKAGECONFIG_remove = "kvm"
24
25# Enable libgcrypt
26PACKAGECONFIG_append = " gcrypt"
27
28DISABLE_STATIC_pn-${PN} = ""
29
30PTEST_ENABLED = ""
31
32# append a suffix dir, to allow multiple versions of QEMU to be installed
33EXTRA_OECONF_append = " \
34 --bindir=${bindir}/qemu-xilinx \
35 --libexecdir=${libexecdir}/qemu-xilinx \
36 "
37
38do_configure_prepend() {
39 # rewrite usage of 'libgcrypt-config' with 'pkg-config libgcrypt'
40 sed -r -i 's/libgcrypt-config(\s*--)/pkg-config libgcrypt\1/g' ${S}/configure
41}
42
43do_install_append() {
44 # Prevent QA warnings about installed ${localstatedir}/run
45 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
46}
47
diff --git a/recipes-devtools/qemu/qemu-xilinx_2017.3.bb b/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
deleted file mode 100644
index f8a91d75..00000000
--- a/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require qemu-xilinx.inc
2
3XILINX_RELEASE_VERSION = "v2017.3"
4XILINX_QEMU_VERSION = "v2.8.1"
5SRCREV ?= "8f8c89b18f6e4523099e41d81769fc534064b8de"