summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-01-05 01:22:09 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-03-10 01:33:42 +1000
commit96755b4a5ee5d329f4a12a138706121368d6db51 (patch)
treec32dc9ec7de517f8c9e971d96bf071f6198324e9 /recipes-devtools
parent5f0cc3cc149f6073f00f43c81db22aa695ebb325 (diff)
downloadmeta-xilinx-96755b4a5ee5d329f4a12a138706121368d6db51.tar.gz
qemu-xilinx: Updates for libgcrypt and improved qemu.inc
Update the append to work with the improved qemu.inc. Enable gcrypt PACKAGECONFIG options. In order to enable libgcrypt the QEMU configure must be patched to handle pkg-config support for libgcrypt. This is because upstream libgcrypt does not provide pkg-config support but OE does. The solution used works around the need to patch QEMU, by implementing the patch as a sed replace so that a patch does not need to be used and maintained across versions. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-xilinx_2017.1.bb23
1 files changed, 11 insertions, 12 deletions
diff --git a/recipes-devtools/qemu/qemu-xilinx_2017.1.bb b/recipes-devtools/qemu/qemu-xilinx_2017.1.bb
index f291ebb4..8fba4d1f 100644
--- a/recipes-devtools/qemu/qemu-xilinx_2017.1.bb
+++ b/recipes-devtools/qemu/qemu-xilinx_2017.1.bb
@@ -11,20 +11,17 @@ LIC_FILES_CHKSUM = " \
11 " 11 "
12 12
13SRCREV = "a83265d7403ee49c9a911c920961ef29deac96eb" 13SRCREV = "a83265d7403ee49c9a911c920961ef29deac96eb"
14SRC_URI = "git://github.com/Xilinx/qemu.git;protocol=https;nobranch=1 \ 14SRC_URI = "git://github.com/Xilinx/qemu.git;protocol=https;nobranch=1"
15 "
16 15
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19# Disable KVM completely 18# Disable KVM completely
20KVMENABLE = "--disable-kvm" 19PACKAGECONFIG_remove = "kvm"
21 20
22# Strip all appends (needed because qemu.inc adds patches using overrides) 21# Enable libgcrypt
23SRC_URI[_append] = "" 22PACKAGECONFIG_append = " gcrypt"
24 23
25DISABLE_STATIC_pn-qemu-xilinx = "" 24DISABLE_STATIC_pn-${PN} = ""
26DISABLE_STATIC_pn-qemu-xilinx-native = ""
27DISABLE_STATIC_pn-nativesdk-qemu-xilinx = ""
28 25
29PTEST_ENABLED = "" 26PTEST_ENABLED = ""
30 27
@@ -32,13 +29,15 @@ PTEST_ENABLED = ""
32EXTRA_OECONF_append = " \ 29EXTRA_OECONF_append = " \
33 --bindir=${bindir}/qemu-xilinx \ 30 --bindir=${bindir}/qemu-xilinx \
34 --libexecdir=${libexecdir}/qemu-xilinx \ 31 --libexecdir=${libexecdir}/qemu-xilinx \
35 --datadir=${datadir}/qemu-xilinx \
36 " 32 "
37 33
38do_install() { 34do_configure_prepend() {
39 export STRIP="true" 35 # rewrite usage of 'libgcrypt-config' with 'pkg-config libgcrypt'
40 autotools_do_install 36 sed -r -i 's/libgcrypt-config(\s*--)/pkg-config libgcrypt\1/g' ${S}/configure
37}
41 38
39do_install_append() {
42 # Prevent QA warnings about installed ${localstatedir}/run 40 # Prevent QA warnings about installed ${localstatedir}/run
43 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi 41 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
44} 42}
43