summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2014-08-12 16:39:01 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2014-08-12 16:39:01 +1000
commit83bf54daeaca21879290bf444876f9949b117454 (patch)
tree56bda049767f5a21ea4c3767283bac3c93d396d3 /recipes-devtools
parent941bd7528927c5ac8d9424cacce4e5bc9ba030ac (diff)
downloadmeta-xilinx-83bf54daeaca21879290bf444876f9949b117454.tar.gz
qemu: Updated version
* There are no longer any patches on QEMU for MicroBlaze or Zynq, mainline QEMU in 2.1.0+ provides functional models of MicroBlaze and Zynq machines * Switch recipe to wildcard version as no version dependence exists in the bbappend Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/files/HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch48
-rw-r--r--recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch37
-rw-r--r--recipes-devtools/qemu/qemu_%.bbappend2
-rw-r--r--recipes-devtools/qemu/qemu_2.0.0.bbappend7
4 files changed, 2 insertions, 92 deletions
diff --git a/recipes-devtools/qemu/files/HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch b/recipes-devtools/qemu/files/HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch
deleted file mode 100644
index 527422b5..00000000
--- a/recipes-devtools/qemu/files/HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
2Date: Wed, 27 Mar 2013 02:00:09 +0000
3Subject: HACK: zynq_slcr: Bring SLCR out of reset in kernel state
4
5Reset the zynq_slcr into something more closely resembling the post
6FSBL handoff state. Needed to keep the Linux clock framework happy.
7
8I can only apply this patch (in its current form), to the workarounds
9branch but I am RFCing it, as if there are any other things I should
10be changing, let me know! I'll factor them into a real solution.
11
12Cc: sorenb@xilinx.com
13Cc: michal.simek@xilinx.com
14Signed-off-by: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
15---
16diff --git a/hw/misc/zynq_slcr.c b/hw/misc/zynq_slcr.c
17index 872ba3f..8f3e614 100644
18--- a/hw/misc/zynq_slcr.c
19+++ b/hw/misc/zynq_slcr.c
20@@ -243,19 +243,19 @@ static void zynq_slcr_reset(DeviceState *d)
21
22 s->lockval = 1;
23 /* 0x100 - 0x11C */
24- s->pll[ARM_PLL_CTRL] = 0x0001A008;
25- s->pll[DDR_PLL_CTRL] = 0x0001A008;
26- s->pll[IO_PLL_CTRL] = 0x0001A008;
27+ s->pll[ARM_PLL_CTRL] = 0x00028008;
28+ s->pll[DDR_PLL_CTRL] = 0x00020008;
29+ s->pll[IO_PLL_CTRL] = 0x0001e008;
30 s->pll[PLL_STATUS] = 0x0000003F;
31- s->pll[ARM_PPL_CFG] = 0x00014000;
32- s->pll[DDR_PLL_CFG] = 0x00014000;
33- s->pll[IO_PLL_CFG] = 0x00014000;
34+ s->pll[ARM_PPL_CFG] = 0x000fa220;
35+ s->pll[DDR_PLL_CFG] = 0x0012c220;
36+ s->pll[IO_PLL_CFG] = 0x001452c0;
37
38 /* 0x120 - 0x16C */
39- s->clk[ARM_CLK_CTRL] = 0x1F000400;
40+ s->clk[ARM_CLK_CTRL] = 0x1F000200;
41 s->clk[DDR_CLK_CTRL] = 0x18400003;
42 s->clk[DCI_CLK_CTRL] = 0x01E03201;
43- s->clk[APER_CLK_CTRL] = 0x01FFCCCD;
44+ s->clk[APER_CLK_CTRL] = 0x01ed044d;
45 s->clk[USB0_CLK_CTRL] = s->clk[USB1_CLK_CTRL] = 0x00101941;
46 s->clk[GEM0_RCLK_CTRL] = s->clk[GEM1_RCLK_CTRL] = 0x00000001;
47 s->clk[GEM0_CLK_CTRL] = s->clk[GEM1_CLK_CTRL] = 0x00003C01;
48--
diff --git a/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch b/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch
deleted file mode 100644
index 8e8032e9..00000000
--- a/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From f663faac3e2e9d9134415f75d429ae30432e6038 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan.rossi@xilinx.com>
3Date: Tue, 8 Apr 2014 18:52:39 -0700
4Subject: [PATCH] net: xilinx_axienet.c: Add phy soft reset bit clearing
5
6Clear the BMCR Reset when writing to registers.
7
8Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
9[ PC:
10 * Trivial style fixes to commit message
11]
12Signed-off-by: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
13Reviewed-by: Beniamino Galvani <b.galvani@gmail.com>
14Reviewed-by: Edgar E. Iglesias <edgar.iglesias@gmail.com>
15Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
16Upstream-Status: Backport
17---
18 hw/net/xilinx_axienet.c | 3 +++
19 1 file changed, 3 insertions(+)
20
21diff --git a/hw/net/xilinx_axienet.c b/hw/net/xilinx_axienet.c
22index 839d97c..0f485a0 100644
23--- a/hw/net/xilinx_axienet.c
24+++ b/hw/net/xilinx_axienet.c
25@@ -142,6 +142,9 @@ tdk_write(struct PHY *phy, unsigned int req, unsigned int data)
26 phy->regs[regnum] = data;
27 break;
28 }
29+
30+ /* Unconditionally clear regs[BMCR][BMCR_RESET] */
31+ phy->regs[0] &= ~0x8000;
32 }
33
34 static void
35--
361.9.0
37
diff --git a/recipes-devtools/qemu/qemu_%.bbappend b/recipes-devtools/qemu/qemu_%.bbappend
new file mode 100644
index 00000000..4c37b1e0
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_%.bbappend
@@ -0,0 +1,2 @@
1QEMU_TARGETS += "microblazeel"
2
diff --git a/recipes-devtools/qemu/qemu_2.0.0.bbappend b/recipes-devtools/qemu/qemu_2.0.0.bbappend
deleted file mode 100644
index 01f76bb4..00000000
--- a/recipes-devtools/qemu/qemu_2.0.0.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
1QEMU_TARGETS += "microblazeel"
2
3FILESEXTRAPATHS_append := "${THISDIR}/files:"
4SRC_URI_append += " \
5 file://HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch \
6 file://net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch \
7 "