summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2016-09-22 23:56:43 +1000
committerNathan Rossi <nathan@nathanrossi.com>2016-10-11 21:10:52 +1000
commit71258dd283b925633f6b308a20e7fbfac9cd6b71 (patch)
tree5b25db3fbe09d33f160f1d3443aa4d170dc6e91c /recipes-devtools
parentcdd5a11313fe864d09358341c82d9a900c874c35 (diff)
downloadmeta-xilinx-71258dd283b925633f6b308a20e7fbfac9cd6b71.tar.gz
recipes-{zynqmp -> devtools}: Move the QEMU appends to generic dir
Move the QEMU appends and patches to a generic directory. This is so that patches can be for different target SoCs/etc. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Reviewed-by: Alistair Francis <alistair.francis@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch30
-rw-r--r--recipes-devtools/qemu/qemu_2.7%.bbappend7
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch b/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch
new file mode 100644
index 00000000..f266d6d2
--- /dev/null
+++ b/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch
@@ -0,0 +1,30 @@
1From 8fa2346723fb74e8220ac9f186dabc2f57e4cb43 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@xilinx.com>
3Date: Wed, 15 Jun 2016 10:39:55 -0700
4Subject: [PATCH] target-arm: Disable EL3 on A53
5
6The Xilinx kernel doesn't support having EL3 enabled and EL2 disabled.
7As EL2 is not yet supported on mainline QEMU disable EL3 until we can
8support a complete boot flow.
9
10Signed-off-by: Alistair Francis <alistair.francis@xilinx.com>
11Upstream-Status: Inappropriate [workaround feature incompatibility]
12---
13 target-arm/cpu64.c | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/target-arm/cpu64.c b/target-arm/cpu64.c
17index 1635deb..0896259 100644
18--- a/target-arm/cpu64.c
19+++ b/target-arm/cpu64.c
20@@ -165,7 +165,6 @@ static void aarch64_a53_initfn(Object *obj)
21 set_feature(&cpu->env, ARM_FEATURE_V8_SHA256);
22 set_feature(&cpu->env, ARM_FEATURE_V8_PMULL);
23 set_feature(&cpu->env, ARM_FEATURE_CRC);
24- set_feature(&cpu->env, ARM_FEATURE_EL3);
25 cpu->kvm_target = QEMU_KVM_ARM_TARGET_CORTEX_A53;
26 cpu->midr = 0x410fd034;
27 cpu->revidr = 0x00000000;
28--
292.7.4
30
diff --git a/recipes-devtools/qemu/qemu_2.7%.bbappend b/recipes-devtools/qemu/qemu_2.7%.bbappend
new file mode 100644
index 00000000..eb66caed
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_2.7%.bbappend
@@ -0,0 +1,7 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4SRC_URI += " \
5 file://8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch \
6 "
7