summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2014-06-10 10:52:24 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2014-06-10 10:52:24 +1000
commit63330ee31df62743aa6a74e54320566da320dda1 (patch)
treee0964e7f0fa3761dba22ed78c5331c9676ecc47b /recipes-devtools
parent237fc5318f5e589dd036152ac583d58868019104 (diff)
downloadmeta-xilinx-63330ee31df62743aa6a74e54320566da320dda1.tar.gz
qemu: Fix axi-ethernet for newer kernels
* Backport patch from upstream which fixes axi-ethernet phy accesses with newer kernels Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch37
-rw-r--r--recipes-devtools/qemu/qemu_2.0.0.bbappend1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch b/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch
new file mode 100644
index 00000000..8e8032e9
--- /dev/null
+++ b/recipes-devtools/qemu/files/net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch
@@ -0,0 +1,37 @@
1From f663faac3e2e9d9134415f75d429ae30432e6038 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan.rossi@xilinx.com>
3Date: Tue, 8 Apr 2014 18:52:39 -0700
4Subject: [PATCH] net: xilinx_axienet.c: Add phy soft reset bit clearing
5
6Clear the BMCR Reset when writing to registers.
7
8Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
9[ PC:
10 * Trivial style fixes to commit message
11]
12Signed-off-by: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
13Reviewed-by: Beniamino Galvani <b.galvani@gmail.com>
14Reviewed-by: Edgar E. Iglesias <edgar.iglesias@gmail.com>
15Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
16Upstream-Status: Backport
17---
18 hw/net/xilinx_axienet.c | 3 +++
19 1 file changed, 3 insertions(+)
20
21diff --git a/hw/net/xilinx_axienet.c b/hw/net/xilinx_axienet.c
22index 839d97c..0f485a0 100644
23--- a/hw/net/xilinx_axienet.c
24+++ b/hw/net/xilinx_axienet.c
25@@ -142,6 +142,9 @@ tdk_write(struct PHY *phy, unsigned int req, unsigned int data)
26 phy->regs[regnum] = data;
27 break;
28 }
29+
30+ /* Unconditionally clear regs[BMCR][BMCR_RESET] */
31+ phy->regs[0] &= ~0x8000;
32 }
33
34 static void
35--
361.9.0
37
diff --git a/recipes-devtools/qemu/qemu_2.0.0.bbappend b/recipes-devtools/qemu/qemu_2.0.0.bbappend
index 94296457..01f76bb4 100644
--- a/recipes-devtools/qemu/qemu_2.0.0.bbappend
+++ b/recipes-devtools/qemu/qemu_2.0.0.bbappend
@@ -3,4 +3,5 @@ QEMU_TARGETS += "microblazeel"
3FILESEXTRAPATHS_append := "${THISDIR}/files:" 3FILESEXTRAPATHS_append := "${THISDIR}/files:"
4SRC_URI_append += " \ 4SRC_URI_append += " \
5 file://HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch \ 5 file://HACK_zynq_slcr_Bring_SLCR_out_of_reset_in_kernel_state.patch \
6 file://net-xilinx_axienet.c-Add-phy-soft-reset-bit-clearing.patch \
6 " 7 "