summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@xilinx.com>2017-02-09 16:46:24 -0800
committerNathan Rossi <nathan@nathanrossi.com>2017-02-11 00:06:11 +1000
commit2426078d00b6022b69ced08c1cbeabb491beb10b (patch)
tree78347492de856b3f4fdd7a86e05c82c7e1ee67bb /recipes-devtools
parentf6f63d2657e63f32b0e104c7429f333d5d9e6213 (diff)
downloadmeta-xilinx-2426078d00b6022b69ced08c1cbeabb491beb10b.tar.gz
qemu: mainline: Remove patches for mainline QEMU
OE-Core updated to QEMU 2.8 and these patches are no longer required. Just delete all changes made to mainline QEMU in meta-xilinx. Signed-off-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch30
-rw-r--r--recipes-devtools/qemu/files/dma-xlnx-zynq-devcfg.patch55
-rw-r--r--recipes-devtools/qemu/qemu_2.7%.bbappend8
3 files changed, 0 insertions, 93 deletions
diff --git a/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch b/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch
deleted file mode 100644
index f266d6d2..00000000
--- a/recipes-devtools/qemu/files/8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 8fa2346723fb74e8220ac9f186dabc2f57e4cb43 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@xilinx.com>
3Date: Wed, 15 Jun 2016 10:39:55 -0700
4Subject: [PATCH] target-arm: Disable EL3 on A53
5
6The Xilinx kernel doesn't support having EL3 enabled and EL2 disabled.
7As EL2 is not yet supported on mainline QEMU disable EL3 until we can
8support a complete boot flow.
9
10Signed-off-by: Alistair Francis <alistair.francis@xilinx.com>
11Upstream-Status: Inappropriate [workaround feature incompatibility]
12---
13 target-arm/cpu64.c | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/target-arm/cpu64.c b/target-arm/cpu64.c
17index 1635deb..0896259 100644
18--- a/target-arm/cpu64.c
19+++ b/target-arm/cpu64.c
20@@ -165,7 +165,6 @@ static void aarch64_a53_initfn(Object *obj)
21 set_feature(&cpu->env, ARM_FEATURE_V8_SHA256);
22 set_feature(&cpu->env, ARM_FEATURE_V8_PMULL);
23 set_feature(&cpu->env, ARM_FEATURE_CRC);
24- set_feature(&cpu->env, ARM_FEATURE_EL3);
25 cpu->kvm_target = QEMU_KVM_ARM_TARGET_CORTEX_A53;
26 cpu->midr = 0x410fd034;
27 cpu->revidr = 0x00000000;
28--
292.7.4
30
diff --git a/recipes-devtools/qemu/files/dma-xlnx-zynq-devcfg.patch b/recipes-devtools/qemu/files/dma-xlnx-zynq-devcfg.patch
deleted file mode 100644
index eb6a5871..00000000
--- a/recipes-devtools/qemu/files/dma-xlnx-zynq-devcfg.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From a43639b12daff2230a98faffcffc79346c8ebf8c Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Thu, 22 Sep 2016 18:13:08 +0100
4Subject: [PATCH] dma: xlnx-zynq-devcfg: Fix up XLNX_ZYNQ_DEVCFG_R_MAX
5
6Whilst according to the Zynq TRM this device covers a register region of
70x000 - 0x120. The register region is also shared with XADCIF prefix
8registers at 0x100 and above. Due to how the devcfg and the xadc devices
9are implemented in QEMU these are separate models with individual mmio
10regions. As such the region registered by the devcfg overlaps with the
11xadc when initialized in a machine model (e.g. xilinx-zynq-a9).
12
13This patch fixes up the incorrect region size, where
14XLNX_ZYNQ_DEVCFG_R_MAX is missing its '/ 4' causing it to be 0x460 in
15size. As well as setting the region size to the 0x0 - 0x100 region so
16that an xadc device instance can be registered in the correct region to
17pair with the devcfg device instance.
18
19Mapping with XLNX_ZYNQ_DEVCFG_R_MAX = 0x118:
20 dev: xlnx.ps7-dev-cfg, id ""
21 mmio 00000000f8007000/0000000000000460
22 dev: xlnx,zynq-xadc, id ""
23 mmio 00000000f8007100/0000000000000020
24
25Mapping with XLNX_ZYNQ_DEVCFG_R_MAX = 0x100 / 4:
26 dev: xlnx.ps7-dev-cfg, id ""
27 mmio 00000000f8007000/0000000000000100
28 dev: xlnx,zynq-xadc, id ""
29 mmio 00000000f8007100/0000000000000020
30
31Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
32Reviewed-by: Alistair Francis <alistair.francis@xilinx.com>
33Message-id: 20160921180911.32289-1-nathan@nathanrossi.com
34Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
35Upstream-Status: Backport
36---
37 include/hw/dma/xlnx-zynq-devcfg.h | 2 +-
38 1 file changed, 1 insertion(+), 1 deletion(-)
39
40diff --git a/include/hw/dma/xlnx-zynq-devcfg.h b/include/hw/dma/xlnx-zynq-devcfg.h
41index d40e5c8df6..9f5119a89a 100644
42--- a/include/hw/dma/xlnx-zynq-devcfg.h
43+++ b/include/hw/dma/xlnx-zynq-devcfg.h
44@@ -34,7 +34,7 @@
45 #define XLNX_ZYNQ_DEVCFG(obj) \
46 OBJECT_CHECK(XlnxZynqDevcfg, (obj), TYPE_XLNX_ZYNQ_DEVCFG)
47
48-#define XLNX_ZYNQ_DEVCFG_R_MAX 0x118
49+#define XLNX_ZYNQ_DEVCFG_R_MAX (0x100 / 4)
50
51 #define XLNX_ZYNQ_DEVCFG_DMA_CMD_FIFO_LEN 10
52
53--
542.9.3
55
diff --git a/recipes-devtools/qemu/qemu_2.7%.bbappend b/recipes-devtools/qemu/qemu_2.7%.bbappend
deleted file mode 100644
index 60ae486d..00000000
--- a/recipes-devtools/qemu/qemu_2.7%.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4SRC_URI += " \
5 file://8fa2346723fb74e8220ac9f186dabc2f57e4cb43.patch \
6 file://dma-xlnx-zynq-devcfg.patch \
7 "
8