summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2014-12-17 17:23:14 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2014-12-17 17:23:14 +1000
commit05ca55921548e949c7c95f9a85c568a673d4ad40 (patch)
tree864712bfe681810dd75cea288e0dcb9bdb43d46d /recipes-devtools
parent7f759048bb0aeef3c0b3938be81d2bcade7acb7e (diff)
downloadmeta-xilinx-05ca55921548e949c7c95f9a85c568a673d4ad40.tar.gz
gdb: Port gdb 7.7.1 recipes from oe-core
* Port the gdb 7.7.1 recipes from oe-core, this is due to issues with re-producing a functional gdb for 7.8.1+ * Default MicroBlaze machines to use gdb 7.7.1 Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gdb/gdb-7.7.1.inc11
-rw-r--r--recipes-devtools/gdb/gdb-cross-canadian_7.7%.bbappend1
-rw-r--r--recipes-devtools/gdb/gdb-cross-canadian_7.7.1.bb4
-rw-r--r--recipes-devtools/gdb/gdb-cross_7.7%.bbappend1
-rw-r--r--recipes-devtools/gdb/gdb-cross_7.7.1.bb3
-rw-r--r--recipes-devtools/gdb/gdb_7.7%.bbappend1
-rw-r--r--recipes-devtools/gdb/gdb_7.7.1.bb29
7 files changed, 47 insertions, 3 deletions
diff --git a/recipes-devtools/gdb/gdb-7.7.1.inc b/recipes-devtools/gdb/gdb-7.7.1.inc
new file mode 100644
index 00000000..04488e9e
--- /dev/null
+++ b/recipes-devtools/gdb/gdb-7.7.1.inc
@@ -0,0 +1,11 @@
1LICENSE = "GPLv2 & GPLv3 & LGPLv2 & LGPLv3"
2LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
3 file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
5 file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674"
6
7S = "${WORKDIR}/${BPN}-${PV}"
8
9SRC_URI[md5sum] = "45b07b53d81832d32ccd4829465d4886"
10SRC_URI[sha256sum] = "eefadb9831e3695d1eaef34e98b8f1fb441df6fe5071317ea49c6bd6ba213eff"
11
diff --git a/recipes-devtools/gdb/gdb-cross-canadian_7.7%.bbappend b/recipes-devtools/gdb/gdb-cross-canadian_7.7%.bbappend
deleted file mode 100644
index 2d7cc4fe..00000000
--- a/recipes-devtools/gdb/gdb-cross-canadian_7.7%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gdb-microblaze-7.7.inc
diff --git a/recipes-devtools/gdb/gdb-cross-canadian_7.7.1.bb b/recipes-devtools/gdb/gdb-cross-canadian_7.7.1.bb
new file mode 100644
index 00000000..c349ebbb
--- /dev/null
+++ b/recipes-devtools/gdb/gdb-cross-canadian_7.7.1.bb
@@ -0,0 +1,4 @@
1require recipes-devtools/gdb/gdb-common.inc
2require recipes-devtools/gdb/gdb-cross-canadian.inc
3require gdb-${PV}.inc
4require gdb-microblaze-7.7.inc
diff --git a/recipes-devtools/gdb/gdb-cross_7.7%.bbappend b/recipes-devtools/gdb/gdb-cross_7.7%.bbappend
deleted file mode 100644
index 2d7cc4fe..00000000
--- a/recipes-devtools/gdb/gdb-cross_7.7%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gdb-microblaze-7.7.inc
diff --git a/recipes-devtools/gdb/gdb-cross_7.7.1.bb b/recipes-devtools/gdb/gdb-cross_7.7.1.bb
new file mode 100644
index 00000000..98b3359c
--- /dev/null
+++ b/recipes-devtools/gdb/gdb-cross_7.7.1.bb
@@ -0,0 +1,3 @@
1require recipes-devtools/gdb/gdb-cross.inc
2require gdb-${PV}.inc
3require gdb-microblaze-7.7.inc
diff --git a/recipes-devtools/gdb/gdb_7.7%.bbappend b/recipes-devtools/gdb/gdb_7.7%.bbappend
deleted file mode 100644
index 2d7cc4fe..00000000
--- a/recipes-devtools/gdb/gdb_7.7%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require gdb-microblaze-7.7.inc
diff --git a/recipes-devtools/gdb/gdb_7.7.1.bb b/recipes-devtools/gdb/gdb_7.7.1.bb
new file mode 100644
index 00000000..80b589a1
--- /dev/null
+++ b/recipes-devtools/gdb/gdb_7.7.1.bb
@@ -0,0 +1,29 @@
1require recipes-devtools/gdb/gdb-common.inc
2require gdb-${PV}.inc
3require gdb-microblaze-7.7.inc
4
5inherit gettext
6inherit python-dir
7
8PACKAGECONFIG ??= ""
9PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
10PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
11
12do_configure_prepend() {
13 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
14 cat > ${WORKDIR}/python << EOF
15#!/bin/sh
16case "\$2" in
17 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
18 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
19 --exec-prefix) echo "${exec_prefix}" ;;
20 *) exit 1 ;;
21esac
22exit 0
23EOF
24 chmod +x ${WORKDIR}/python
25 fi
26}
27
28PACKAGES =+ "gdbserver"
29FILES_gdbserver = "${bindir}/gdbserver"