summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@petalogix.com>2012-09-27 16:32:23 +1000
committerNathan Rossi <nathan.rossi@petalogix.com>2012-09-27 16:32:23 +1000
commitcba63460c62e458ce01440445834b1356427aee6 (patch)
tree41e3419f7acdda8d37ee1430436b2450cde9489b /recipes-core
parent3af2a854f47719c5847ba2f9bca59e888e82cb26 (diff)
downloadmeta-xilinx-cba63460c62e458ce01440445834b1356427aee6.tar.gz
image-tiny: Created a core image which is smaller
'core-image-tiny' intends to be smaller then 'core-image-minimal'. Signed-off-by: Nathan Rossi <nathan.rossi@petalogix.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/core-image-tiny.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-tiny.bb b/recipes-core/images/core-image-tiny.bb
new file mode 100644
index 00000000..ed0994ed
--- /dev/null
+++ b/recipes-core/images/core-image-tiny.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "A tiny image just capable of allowing a device to boot."
2
3IMAGE_INSTALL = "base-files \
4 base-passwd \
5 busybox \
6 busybox-mdev \
7 initscripts \
8 modutils-initscripts \
9 netbase \
10 tinylogin \
11 sysvinit \
12 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
13 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
14 ${CORE_IMAGE_EXTRA_INSTALL}"
15
16IMAGE_LINGUAS = " "
17
18LICENSE = "MIT"
19
20inherit core-image
21
22IMAGE_ROOTFS_SIZE = "8192"
23
24# remove not needed ipkg informations
25ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "