summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@xilinx.com>2013-05-22 06:47:55 +1000
committerSipke Vriend <sipke.vriend@xilinx.com>2013-05-22 06:47:55 +1000
commitb2c97e854f43de2483c8663c0be6c1c0f5e4fab3 (patch)
treeec3daa9928e961fde53dabc839df7de31d80a2d3 /recipes-core
parent4003c87c7cbfe8f19dddaf8c42d1fe209a4638ba (diff)
downloadmeta-xilinx-b2c97e854f43de2483c8663c0be6c1c0f5e4fab3.tar.gz
Remove rootfs symlink generation.
Signed-off-by: Sipke Vriend <sipke.vriend@xilinx.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/core-image-minimal.bbappend2
-rw-r--r--recipes-core/images/rootfs-extra.inc16
2 files changed, 0 insertions, 18 deletions
diff --git a/recipes-core/images/core-image-minimal.bbappend b/recipes-core/images/core-image-minimal.bbappend
deleted file mode 100644
index ebd015f1..00000000
--- a/recipes-core/images/core-image-minimal.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
1
2include rootfs-extra.inc \ No newline at end of file
diff --git a/recipes-core/images/rootfs-extra.inc b/recipes-core/images/rootfs-extra.inc
deleted file mode 100644
index 8919463b..00000000
--- a/recipes-core/images/rootfs-extra.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1# File containing rootfs related tasks
2
3# Create links to match Xilinx uboot default names
4# Do this silently as they may not exist depending on configuration
5
6# When booting with sd card, Xilinx u-boot by default expects
7# the rootfs as a u-boot-mkimage wrapped file called uramdisk.image.gz,
8# so for convenience symlink the ext2.gz.u-boot file.
9# Confirm if all bsps need this?
10SRC_MKIMAGE_ROOTFS ?= "${IMAGE_NAME}.rootfs.ext2.gz.u-boot"
11SYMLINK_URAMDISK ?= "uramdisk.image.gz"
12do_rootfs_append() {
13 cd ${DEPLOY_DIR_IMAGE}
14 rm -f ${SYMLINK_URAMDISK}
15 ln -sf ${SRC_MKIMAGE_ROOTFS} ${SYMLINK_URAMDISK}
16}