summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-06 16:06:35 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-13 16:11:14 -0800
commita18947c20dba2c0c38db8bde1ad4684995df4bbd (patch)
tree917bf2abbe439a6f99ede8cfafb25812dca54a9a /recipes-core
parent6ddc5873b0ede30e6542f0ab151a6236acc37944 (diff)
downloadmeta-xilinx-a18947c20dba2c0c38db8bde1ad4684995df4bbd.tar.gz
meta-xilinx: Restructuring meta-xilinx to support multiple layers
As discussed previously on mailing list, we are proceeding with layer restructuring. For rocko release we will have the following layers meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-xilinx-contrib In the subsequent releases we will add other layers from Xilinx meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-petalinux ->meta-xilinx-tools ->meta-xilinx-contrib This will provide one clone to get all the required meta layers from Xilinx for a complete solution, and the users can blacklist any layer which they don't want to use using bblayer.conf. This will enables us to help our vendors/partners to add their reference designs, board definitions etc. Recipe changes : * Move reference design zybo-linux-bd.bb to meta-xilinx-contrib * Move kernel patches realted to zybo-linux-bd-zynq7 board to meta-xilinx-contrib * Update README Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/newlib/libgloss_2.5.0.bb18
-rw-r--r--recipes-core/newlib/newlib.inc59
-rw-r--r--recipes-core/newlib/newlib_2.5.0.bb11
3 files changed, 0 insertions, 88 deletions
diff --git a/recipes-core/newlib/libgloss_2.5.0.bb b/recipes-core/newlib/libgloss_2.5.0.bb
deleted file mode 100644
index 6fbafc1d..00000000
--- a/recipes-core/newlib/libgloss_2.5.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1
2require newlib.inc
3
4DEPENDS += "newlib"
5
6do_configure() {
7 ${S}/libgloss/configure ${CONFIGUREOPTS}
8}
9
10do_install_prepend() {
11 # install doesn't create this itself
12 install -d ${D}${prefix}/${TARGET_SYS}/lib
13}
14
15FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
16
17INHIBIT_PACKAGE_STRIP = "1"
18INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-core/newlib/newlib.inc b/recipes-core/newlib/newlib.inc
deleted file mode 100644
index 2fb2301d..00000000
--- a/recipes-core/newlib/newlib.inc
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "Newlib is a C library intended for use on embedded systems"
2HOMEPAGE = "https://sourceware.org/newlib/"
3DESCRIPTION = "It is a conglomeration of several library parts, all under free software licenses that make them easily usable on embedded products."
4SECTION = "libs"
5
6LICENSE = "GPLv2 & LGPLv3 & GPLv3 & LGPLv2"
7LIC_FILES_CHKSUM = " \
8 file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
9 file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
10 file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
11 file://COPYING.LIBGLOSS;md5=73f5c98779aea7dba4a6c94a74ab0ae2 \
12 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
13 file://COPYING.NEWLIB;md5=bfdd6396bf3b02bd23ffbb9f7ddfbec6 \
14 file://newlib/libc/posix/COPYRIGHT;md5=103468ff1982be840fdf4ee9f8b51bbf \
15 file://newlib/libc/sys/linux/linuxthreads/LICENSE;md5=73640207fbc79b198c7ffd4ad4d97aa0 \
16 "
17
18SRC_URI = "ftp://sourceware.org/pub/newlib/newlib-${PV}.tar.gz"
19SRC_URI[md5sum] = "767dc60aaf814d091997d91d588968b2"
20SRC_URI[sha256sum] = "5b76a9b97c9464209772ed25ce55181a7bb144a66e5669aaec945aa64da3189b"
21
22INHIBIT_DEFAULT_DEPS = "1"
23DEPENDS = "virtual/${TARGET_PREFIX}gcc"
24
25S = "${WORKDIR}/newlib-${PV}"
26B = "${WORKDIR}/build"
27
28# disable use of a link hash style
29TARGET_LINK_HASH_STYLE_microblaze = ""
30
31# disable stdlib
32TARGET_CC_ARCH_append = " -nostdlib"
33
34CONFIGUREOPTS = " \
35 --build=${BUILD_SYS} \
36 --host=${HOST_SYS} \
37 --target=${TARGET_SYS} \
38 --prefix=${prefix} \
39 --exec-prefix=${exec_prefix} \
40 --bindir=${bindir} \
41 --libdir=${libdir} \
42 --includedir=${includedir} \
43 --enable-languages=c \
44 --with-newlib \
45 --with-gnu-as \
46 --with-gnu-ld \
47 --disable-multilib \
48 "
49
50do_configure[cleandirs] = "${B}"
51
52do_install() {
53 oe_runmake install DESTDIR='${D}'
54
55 # output of headers/libs in 'tooldir' subdirectories, move it up to the prefix dir.
56 mv ${D}${prefix}/${TARGET_SYS}/* ${D}${prefix}/
57 rmdir ${D}${prefix}/${TARGET_SYS}
58}
59
diff --git a/recipes-core/newlib/newlib_2.5.0.bb b/recipes-core/newlib/newlib_2.5.0.bb
deleted file mode 100644
index dc30c6b2..00000000
--- a/recipes-core/newlib/newlib_2.5.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1
2require newlib.inc
3
4do_configure_prepend_microblaze() {
5 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC)
6 export CC="${CC} -L${S}/libgloss/microblaze"
7}
8
9do_configure() {
10 ${S}/configure ${CONFIGUREOPTS}
11}