summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2012-10-04 18:39:06 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2012-10-04 18:39:06 +1000
commit678832ca2b3f4e6f68a7114b1dd5a839bc3eaf1c (patch)
tree2d979bc335d6501db9b118b0f6a1f489666aae11 /recipes-core
parent8db3a952a4ba49df816c00903fa71c7193278841 (diff)
downloadmeta-xilinx-678832ca2b3f4e6f68a7114b1dd5a839bc3eaf1c.tar.gz
ncurses: Added patch to add "microblazeel" support to config.sub
Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/ncurses/files/config-microblazeel.patch43
-rw-r--r--recipes-core/ncurses/ncurses_5.9.bbappend6
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-core/ncurses/files/config-microblazeel.patch b/recipes-core/ncurses/files/config-microblazeel.patch
new file mode 100644
index 00000000..83146110
--- /dev/null
+++ b/recipes-core/ncurses/files/config-microblazeel.patch
@@ -0,0 +1,43 @@
1Add "microblazeel" target to config.sub.
2
3Index: ncurses/config.sub
4===================================================================
5--- ncurses.orig/config.sub 2011-10-17 19:49:28.000000000 +1000
6+++ ncurses/config.sub 2012-10-04 16:43:53.250376336 +1000
7@@ -154,7 +154,7 @@
8 -convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
9 -c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
10 -harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
11- -apple | -axis | -knuth | -cray | -microblaze)
12+ -apple | -axis | -knuth | -cray | -microblaze | -microblazeel)
13 os=
14 basic_machine=$1
15 ;;
16@@ -260,7 +260,7 @@
17 | ip2k | iq2000 \
18 | lm32 \
19 | m32c | m32r | m32rle | m68000 | m68k | m88k \
20- | maxq | mb | microblaze | mcore | mep | metag \
21+ | maxq | mb | microblaze | microblazeel | mcore | mep | metag \
22 | mips | mipsbe | mipseb | mipsel | mipsle \
23 | mips16 \
24 | mips64 | mips64el \
25@@ -357,7 +357,7 @@
26 | lm32-* \
27 | m32c-* | m32r-* | m32rle-* \
28 | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
29- | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
30+ | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* | microblazeel-* \
31 | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
32 | mips16-* \
33 | mips64-* | mips64el-* \
34@@ -758,6 +758,9 @@
35 microblaze)
36 basic_machine=microblaze-xilinx
37 ;;
38+ microblaze)
39+ basic_machine=microblazeel-xilinx
40+ ;;
41 mingw32)
42 basic_machine=i386-pc
43 os=-mingw32
diff --git a/recipes-core/ncurses/ncurses_5.9.bbappend b/recipes-core/ncurses/ncurses_5.9.bbappend
new file mode 100644
index 00000000..e7a4ac56
--- /dev/null
+++ b/recipes-core/ncurses/ncurses_5.9.bbappend
@@ -0,0 +1,6 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4# Apply patch to add "microblazeel" support to ncurses
5SRC_URI += "file://config-microblazeel.patch"
6